My Book cannot copy file


I have a not so simple problem, i tried to copy some files from my book to pc and i can’t my book either takes a long time or i get I/O errors. BUT i can read and rename them fine. and after renaming the file a can copy it. i i check with error-checking(scandisk and chkdsk) in windows 7 and everything is all fine. don’t really know what’s going on, anyone please help i got aroung 50K+ of files in my 2tb that i really need to copy.

thank you in advance.

it’s a piece of junk dude.   here is a patch to fix it. 

use putty and edit this file /var/oxsemi/network-settings


network_mode=static       this
revert_to_dhcp=no  fill in your ip
static_dns3=  fill in your ip
static_ip=192.168.1.xx fill in your ip.

You can do it by the gui but it wont work.  use the drives for another computer. 

if that works so you can get your info off great if not then it’s your nic card hardware settings. 


now this happend, i remove and waited 5 mins and plug it in again. my wd my book became read only.
i thought it was i windows problem so i rebooted after windows booted up. the external drive is now unallocated. any help recovering the data. both me and my client which i refer you prodect are having the same problem.

it was before i read your post. any advice?

well after searching then net for 3hrs i found what i was looking for it seems that my mbr got corrupted. i tried using ‘testdisk’ but it seems my hd is still in read only mode. so right now i’m now using ‘EaseUS Patition Master’  to repair the mbr.  will post an update after i’m finish

well it seems that my sata0bridge has burns. i manage to get all my data back thru recovery. now using my WD MY BOOK HDD as an internal drive.