My Book 8TB copying error

Hello everyone!

I have been purchasing WD external hard drives for my PC for about 10 years now. I have always been extremely happy with their hard drives. Every two years or so, I buy a new WD hard drive (always upgrading space), and I just copy all of my old files to the new hard drive, and store the old hard drive away in my closet.

In any case, I recently bought a My Book 8TB drive. I ended up having major problems with it, problems I have never experienced in the 10 years I’ve been buying WD hard drives.

After opening the hard drive, I copied all of my files (all digital pictures) to it from my old hard drive (about 319 GB of pictures). I copied it straight to the main hard drive “folder” itself. Like usual, it turned out there were 2 or 3 files that had names that were too big, so it gave me an error message stating something like, “this file is too big to be copied.” This was no big deal. So I changed the name of these two or three files on the original hard drive, and then copied them over to my new hard drive. All was good.

However, then I ran into some significant problems. After copying all files over, I then created a new folder called “Family Pictures” on the new hard drive. I moved all copied files into this new folder. The move completed without any error messages whatsoever. I checked to see how many files were under “Family Pictures” (under “Properties”), and it was the correct number.

However, when I was scrolling through the pictures, I noticed that the thumbnails did not populate for a few pictures. The file was there - the correct name was there too. But when I clicked on it, it was blank and I got the error message, “Windows Photo Viewer can’t open this picture because either Photo Viewer doesn’t support this file format, or you don’t have the latest updates to Photo Viewer.” I knew right away that this was a “bogus” error message; I don’t need any updates, because the same exact picture worked just fine on my original hard drive when I opened it. I knew the copy to the new hard drive didn’t work correctly.

This was highly disturbing to me, because I wouldn’t have known in any way that certain files did not copy over correctly if I hadn’t checked - I never received an error message about this (like I usually always do), and the file appeared in the “file count” accurately. I never had this problem before. Now I’m worried that I might have other files that didn’t copy over correctly. It would take forever for me to check each and every individual file (there are thousands and thousands). How can I fix this? (And more importantly, how do I prevent this from happening in the future?). I don’t know what to call these, but to me they are “ghost” files, because they appear to be there but they are not.

Additionally, I tried to delete the “ghost” files from my hard drive (so that I could rename the original files on my other hard drive with shorter names and then recopy them to the new hard drive). But it wouldn’t let me! I received the error message, “The source file name(s) are larger than is supported by the file system. Try moving to a location which has a shorter path name, or try renaming to shorter name(s) before attempting this operation.” I can’t delete these files, I can’t rename them, I can’t move them - they’re just stuck there. These “ghost” files are now cluttering my hard drive. This is very obnoxious! I googled how to fix this, but I cannot get the “open a command line” solution to work. I also tried disabling the recycling bin, but that doesn’t work either. Does anyone know how I can delete these files???

Finally, I have another problem - when I go to “Properties” under the new hard drive, I see that I have 405 GB of used space on the hard drive. This is insane, because I only copied 319 GB of pictures to the hard drive. What?!?! Where is that extra 86GB of used space coming from? Is that because of the “ghost” files? When I click on the folder I created, “Family Pictures,” it states that this folder takes up 330 GB of space on the hard drive, but the “size on disk” is 388GB. I have no idea what that means, but it seems like I got completely ripped off of 58 GB for no reason (again, is it because of the “ghost” files?).

All of these issues are extraordinarily frustrating, and I have never once encountered any of these issues with a WD hard drive. I am tempted to return this (it seems defective) and switch to another brand if these issues aren’t solved. If anyone knows how to solve any of these problems, I would greatly appreciate it!!

Additionally - even if I do solve these problems, I am now extremely paranoid that I’m going to “think” all of my files copy over to my new hard drive, but in reality some of them might be missing. Is there anyway to absolutely guarantee that all files copy over correctly? I never would have known that some files didn’t copy over correctly if I hadn’t spent 10 minutes randomly clicking a few files.

Thanks so much! Any help is greatly appreciated!!
Tony

Hi CaptainCatholic587,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.