My Book 4TB ext3/ext2 format problems

I have a brand new My Book 4TB. I wanted to attach this drive to my ASUS N66U router and the preferred format on it is ext3/ext2. I tried formatting the drive with ext3/ext2 but no success with this. I’ve tried both using a Linux Mint 16 laptop and a computer booted with latest Gparted live image, but creating the ext partitions have always failed (always with an error that contains “Attempt to read block from filesystem resulted in short read”). I have tried to create single partition for whole disk (4TB) and to split disk into two equally sized partitions (2TB). I tried both with MBR and with GPT. The mkfs command resulted every time in the mentioned error. I have googled and ext3 should able to support such large partitions, so seems there is some issue with the WD drive. The drive can be formatted with NTFS with a single partition for the whole drive.

Has anyone succesfully formatted their My Book with ext3 or ext2?



I would recommend using GPT as opposed to MBR since this disk drive is over 2TB. On the other hand, it is possible an independent application will be able to partition this disk drive as desired in a Microsoft Windows system or an Apple Mac OS system.

Thanks for your reply/tip. 

GPT in use; same problem. 

I have tried to format ext3 with Minitool Partition Wizard Tool in Windows 7; it failed.


This is quite unusual. I would suggest performing a complete drive test using Western Digital Data Lifeguard Diagnostics for Microsoft Windows, then proceeding to write zeros at a low level in order to completely destroy any residual partitioning configuration. Please visit the following link for additional information:


I already downloadedfrom WD support site WD Drive Utilities, and performed the SMART status check, quick drive self-test and full media scan to detect bad sectors. All three tests passed (the last one took many hours). I assume this application is the same tool you mention in your post (even though slightly different name).

You suggest I try low-level formatting by writing zeros to full disc. I assume the WD Drive Utilities Drive Erase does this (it doesn’t say how it erases the disc). Will try it later when I’m sure I’m using the right tool.

Based on your post (and other info I found googling) my understanding is that the drive should succesfully format to ext3 and not fail like it does now. If low-level formatting doesn’t help, then I believe there is nothing further I can try myself. I should probably then return this one to the seller and get another one under warranty?


Indeed the next step would be a replacement under warranty.