My Book 4TB "Corrupted" according to Nvidia Shield

I am not sure exactly which category to post this in, but here goes.

I purchased a 4TB My Book. Connected this to my Nvidia Shield, added some media for Plex. All well. I then decided to remove the HDD and insert it directly to my NAS. This worked well also. I have since decided I want to revert back to the way it was, connecting it via USB 3. I have reversed the removal process, placing the HDD back in the My Book case, and the Shield reports it as “Corrupted”. It connects to my laptop and server via USB cable fine, I have copied stuff, reformatted etc. I have tried different cables. I have tested several other external USB 3 drives on the Shield, and they are fine. I tried the exFat file system and NTFS, no joy.

Any ideas?

I have inserted the drive back into my NAS and it is working as before. It isn’t my ideal solution, and I believe there is a problem with the USB 3 card attached to the HDD.

Someone from reddit has the same problem you with with Seagate drive.

I would suggest you to connect your device back to the PC and do a clean format. Use diskpart to clean and partition the drive as GPT/NTFS.

Hmm. I had previously done both quick and slow formatting via Windows 10. I can confirm that it is currently using GPT/NTFS.

Do you think doing this manually via DiskPart may do something different? I am happy to try, it is just that it takes a while to copy the 2.5TB worth of data back and set up the Plex libraries.