My Book 4TB can't back up files from one of my hard drives

A few days ago I bought a new, WD My Book 4TB External Hard Drive after my previous My Book 3TB external hard stopped working properly by appearing as unformatted drive in my system.

The new My Book 4TB works fine except that it can’t backup files from my system C drive. I use File Backup and want to backup only the Users folder from my C drive. In the Backup Tab, I select the User Folder, click on Apply Changes, and then when I click on Enable Backup, WD SmartWare freezes, I can’t do anything on its window, and the only way to close it is use End Process with the Task Manager. This is not a problem with my other two internal hard drives. Also I don’t see a volume folder created for my C drive when I check the content of My Book at J:\WD SmartWare.swstor\MyComputer while for the other two hard drives I have the volumes with the backup files.

I’m using Windows 7.

When I installed the WD software that came with the new drive, the installer detected that I have already WD SmartWare installed. Currently under the Settings tab it says version 2.1.10. When I check for Software Updates a messages says: “WD SmartWare Is available for update and if I click on Update Software, it downloads a .zip file, opens the Setup Wizard, and when I click Install it completes in a instant. It does that every time I check for software updates with my version remaining 2.1.10 in the Settings tab.

I had similar problems in the past with the backup program with my previous hard drive which stopped working. It wasn’t the C drive but one of the other hard drives. I think I fixed the problem after enabling, and disabling the backup and making changes to the file selection which may have forced the program to refresh its information about the drive. I tried a lot of steps like that for the new hard drive, I even created just one empty simple text document on the root of the hard drive and selected only this file for backup, but nothing worked so far.

I will greatly appreciate your help


I recommend you uninstall WD Smartwasre from the computer and then do a clean install of WD Smartware latest version.

Thank you Hamlet,

this fixed the problem