My Book 3.0 USB 3 2TB does not work on USB 3 but works on USB 2

Hey everyone!

Before I start, please don’t post did you try this or did you try that kind of stuff. Believe me, I tried it all already. Firmware updated (after problem surfaced). Made sure to have the latest NEC USB 3 drivers. Everything! I’m not looking for trouble shooting tips. I am VERY knowledgeable with PC’s and trouble shooting. This is more to see if anyone else is having the same issue as me and if they have a solution.

Anyway…

When I first plugged in the drive, it worked fine with my USB 3 ports but now after 2 weeks it will not show up in Windows anymore.

I tried plugging it into a different USB 3 port and nothing. I tried it on my other PC’s USB 3 ports (4 in total) and same result… it does not show up both in Windows and Disk Management anymore but it does spin up.

So I tried it on another port. It Works! Except it was a USB 2 port. In all, I tried it on 6 different USB 3 ports but it only works on USB 2.0 ports now. What the…!!!

I’ve explored all ways to try and get this thing to work again but I was not able to eliminate the USB cable as a culprit.  It is the only USB 3.0 cable of this kind I have. (the one that came with the drive)  The drive does spin up with the USB cable but nothing else happens. So the cable seems to be OK but I can’t confirm it.

So all my ports work, the power cord works, and the USB 3.0 cable “seems to work”, while the drive now only works on USB 2 ports, but not on the USB 3.0 ports (the whole reason for purchasing this drive).

I ordered another one so we will see what happens. I will be returning the problematic drive once I receive the new one so I can test to see if it was the USB cable or not. I will post my findings soon.

Disappointed!!!

1 Like

So I went and picked up another My Book 3 and hooked it up and it too didn’t work. Now atleast I know it is not the drive.

Through further troubleshooting I finally figured out what was wrong. I thought to my self, what have I done in the last week that might be causing this. A week or so ago I was messing around with my overclock to see how far I could push my  new build. I hit the wall @ about 4.8 GHz and had a BSOD. Thinking back, I thought maybe something got screwy with my BOIS because of the BSOD on the failed overclock. At the time my mobo recovered fine so I thought nothing of it. To make a long story short… I just reset my BIOS to default values and booted up. BAM! It works again. I reapplied my default OC settings and everything is back to normal. Drive works and I am happy again! :slight_smile:

So if you happen to find your WD My Book 3.0 USB 3 2TB acting the same way try resetting you mother board BIOS and see it that fixes the problem. Worked for me.

5 Likes

Excellent insight and troubleshooting.  I’m sure this is important.

Good troubleshooting, and you are a very honest person to admit you traced the problem to something you had done. For such reason is why I never tried overclocking any of my systems, but it would be interesting. I find it pretty cool that you so freely admit to troubleshooting this right down to something you did, I try my best to be the same way, but many techs refuse to consider their own actions as being a possible cause of some problems. ’ sounds like your the kind of tech we need more of in areas like where I live at, even if it’s only a hobby of yours- IT person or hobby, some guys can troubleshoot and some can not, and education level has little to do with it as far as I have seen. I seen high school drop outs figure out problems with company hardware before ENGINEERS did, I see it as a talent like being an artist or a musician.

My soultion was AN EXCHANGE. But, I often wonder if perhaps my problems might of been related to a couple of times my “Books” got knock over from sitting uplike a normal book to a position on there sided. Honestly I do not believe the drives being knocked over did such destruction to them, but it gave me the idea to build a box to hold compartments to securely hold/seperate every needed componet down to the wires, all in a safe manner with a typical usb powered X shape lap dual-fan unit to **bleep** the heat out, and if deemed helpful a smal led might be added. Because I felt so strongly this older style of hard drive was in a need of both cooling and having a location where they could never be knocked over, and while at it I organized the wires ran in straight lines together- tied via ties and left more room in the box for future large hard drives which I assume may be of a smaller design. With the space unalocated in my hard drive box, I figure it could hold over 10 TB at the pace of large external hard drives becoming affordable.

Again, great job troubleshooting!

Oh, I just realized something- For users that still leave System Store turned on I would assume they might simply be able to find a set date from before you made the changes that impacted the USB 3.0 issue.

“Store”=“Restore” (Above)

darn tyos

Interesting.  My PC is overclocked but I bought it that way from a custom builder.  My USB 3.0 port works fine except with Novastor Backup when it freezes (the drive not the software).  If I pause the backup and plug the drive into a USB 2.0 port it picks up  where it lef off  on the the UBB 3.0 port and completes the backup.  Do you think it may be a related issue?

Mike

Hi,

Looks like you’re luckier than I.
Just plugged my brand new 2T My Book Essentials USB3 into my brand new ASUS N53JF laptop’s USB3 port, and the drive and laptop don’t connect using the USB3. Works fine on USB2, but I didn’t buy them for that!

If I can resolve this it’s been a waste of £1000

Win 7 64bit - wonder if it’s that.
No other USB 3 devices so at present I can’t test by subsitution.

Best regards
John

I just reset my ASRock 870 Extreme3 to factory settings, rebooted, and now I’m running a backup without a problem so far. Thanks, this problem was quite vexing!

Check the BIOS and see if the USB 3.0 is enabled.

Joe

This may be an old bump, but I’m having the same issue. When plugged into USB 2, it works flawlessly and I’ve even had to use USB 2 to move a backup file to the drive (which is what I bought this drive for). However, a 700gb image to move over USB 2 took forever. I bought this drive for USB 3 :slight_smile:

Now when I plug it into USB 3 WIndows will still show the device in device manager as the “WD My Book 3.0” but Disk Management reports the disk as RAW. When trying to format it as NTFS (because I don’t need to worry about the data on the drive right now), Windows 7 x64 reports “Windows was unable to complete the format”. I’ve also tried reinstalling the driver just to make sure and nothing seemed to work.

Then I ran across this thread about how having an overclocked system could affect and resolve this issue and since I have an overclocked system (Processor: i7 930 @ 4GHz is only thing overclocked) I decided to reset my BIOS to factory defaults. Did that and the same issue is still happening.

I also think it’s worthy of mentioning that I have an iPad that works fine through USB 3, so I don’t think it’s my motherboard. I’ve contacted WD about an RMA request and they want me to RMA it but I just wanted to run through the forums here to make sure I didn’t miss anything so I wouldn’t be wasting either mine or WD’s time.

Thanks!

PS: Attached image of disk info: diskpart.exe

See if this helps http://www.ehow.com/how_7656415_convert-raw-partition.html

Joe

1 Like

Didn’t work - same issue as before.

I figure I’ll just RMA it once the format is complete over USB 2 (it’s been a day already *sigh*).

I’ll let everyone know what happens.

Hey everyone, I’ve been having similar issue with my MY Book 2TB 3.0 that came with the usb 3.0 adapter. The drive works fine when I plug it into a usb 2.0 drive, and the usb 3.0 adapter recognizes usb 2.0 devices and runs them, but when I plug the drive into the adapter, the fan runs and the drive turns on, but my computer won’t recognize it. I have tried reinstalling the drivers multiple times as well as installing update versions of the driver. I even tried resetting my BIOS with no luck. I have two PCIe x16 ports that I have tried, as well as two of the small PCIe port that fit the adaptor, and nothings has worked. I also updated my bios, with no luck, and I can’t find anything in my systems bios that enables usb 3.0.

I am at a loss of what to do as I have already put a good portion of data on the drive and I don’t want to have to send the entire drive and adapter back just to have them replace the cable or adapter and possible the drive and have to go through the hassle of putting all my data back on the computer, then finding out that the new adapter and cable still don’t work. I called tech support, and the only option available was to do the above, and no real technical support was even given.

Is there anyway I could enable usb 3.0 manually without my bios, or maybe the adapter isn’t getting enough power, and if so, how could I adjust it?

dhcnan

Just a warning never trust important data to just one physical drive internal or external. The board is full of moaning people who did and had a problem. I don’t know about your other problem.

Joe

it wasn’t really important, it was just a good amount of ■■■■ that I don’t want to put back on my computer because of how long it took, and I don’t want to delete it because its still worth something and I don’t want to lose it :stuck_out_tongue:

I got a motherboard GIGABAYTE GA-X58A-UD3R ( USB3). Operating system is win 7 64 bits.  The Book is not recognized. However if I put it on USB2 port it works without any problem. I made update for USB3 port & I change the BIOS to the default but it does not work on USB3 port

Please help. Thanks

I can tell you that this is the case with me as well when I use a USB 3.0 hub.   I have a new Dell XPS 17 core i7 laptop with USB 3 support.  The My Book 3.0 USB 3.0 drive does NOT work with this machine if it is hooked to a USB 3.0 hub (at all - not recognized).   Why I have no idea.  If I use USB 2.0 cables it works just fine, just not in 3.0 mode???

I emailed support and was told that they don’t test them with hubs because they don’t recommend using them with hubs.  HUH?  I think that is a little short sighted as I know that people use them with hubs…isn’t that the beauty of USB that you can use a hub?

Something seems wrong with the USB 3.0 interface on this drive.  If I plug it into my two laptop USB 3.0 ports they work, but now both my 3.0 ports are being used.  What if I want a third drive on USB 3?  I guess I’m out of luck.

My bios is set to boot order: 1. internal drives, 2. DVD drive, 3. usb devices so that is not an issue.  I also played with the USB Emulation settings, made no difference.  I also tried two different hubs from different manufacturers and various cables and neither worked.  I did verify that the correct drivers loaded for each.

I want the drives for the size and speed and hope there is some type of fix in the future so I can get a hub to use with them.  WD needs to do some testing and find out what is going on instead of just glossing over this.

If there is a firmware update that can be made on the drives, we need one!

Boas

My Book WD  2T USB 3, work at 100% on MB Asus Rampage III Estreme. No problem…

Best regards