My Book 3.0 USB 3.0 does not work with USB 3.0 Hubs as a USB 3.0 drive!

I have a new Dell XPS 17 core i7 laptop with USB 3 support.  The My Book 3.0 USB 3.0 drive does NOT work with this machine if it is hooked to a USB 3.0 hub (at all - not recognized and the laptop will not boot).   Why I have no idea.  If I use USB 2.0 cables it works just fine, just not in 3.0 mode???

I emailed support and was told that they don’t test them with hubs because they don’t recommend using them with hubs.  HUH???  I think that is a little short sighted as I know that people use external drives with hubs…isn’t that the beauty of USB that you can use a hub?  I have had many external drives on hubs with NO problems in the past until I got the My Book 3.0.

Something seems wrong with the USB 3.0 interface on this drive.  If I plug it into my two laptop USB 3.0 ports they work, but now both my 3.0 ports are being used.  What if I want a third drive on USB 3?  I guess I’m out of luck.

My laptop BIOS is set to boot order: 1. internal drives, 2. DVD drive, 3. usb devices so that is not an issue.  I also played with the USB Emulation settings, made no difference.  I also tried two different hubs from different manufacturers and various cables and neither worked.  I did verify that the correct drivers loaded for each.  When I boot with the drives attached to the hub, my PC is in molassas…SLOOOOOOOOOOOWWWWWWWWWW…then it hangs and the cooling fan cranks up.  There is no activity light on the drives flashing so it is not indexing as some other post said it probably was.  In fact my Buffalo 1TB USB 2.0 drive by itself on the hub boots right up…no problem.  It is just the WD My Books…

I want these drives for the size and speed (and of course the WD name and quality) and hope there is some type of fix in the future so I can get a hub to use with them.  WD needs to do some testing and find out what is going on instead of just glossing over this.

If there is a firmware update that can be made on the drives, we need one!

Anyone had any luck using a USB 3.0 hub with theirs???

1 Like

They don’t recommend using a hub because hard drives are very sensitive to voltage. A lot of PC makers use a pretty wimpy power supply. If you want to use a hub and risk drive corruption go ahead. Somebody was having trouble booting in USB 2.0 and disabled other devices and it fixed it. And that was after hard drive in BIOS.


Having the exact same problem with the 3TB over usb 3.0

Working when directly connected to motherboard…

Going through a TransImp 4 ports usb 3.0 hub it does not work, and this hub has a Y connector for drawing additional power out of a USB2 port for safety! Still doesnt work! The speed is cut by down 3 times when going through the USB 3.0 hub…

So much for USB3.0 storage array, and here I was trying this one out before being a bunch more! Fix this please WD!

Try setting boot order to boot from just internal HD only. Remove all others - (position 2 and 3 none)

Mabikay - SLK

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.

If I could remove/disable the other devices I would do so but my Dell xps 17 laptop does not have that option in the bios. I can only rearrange the order of the devices.