My Book 3.0 no longer visible on Windows 7 64-bit Ultimate

Hi, I was running along fine with my USB 3.0 My Book 3.0 (2TB) until this afternoon when it was no longer coming up in Windows Explorer when I attached it to my desktop computer.  I tried attaching to both the USB 3.0 port as well as a USB 2.0 port, but with the same results.  It is still recognized ok when I plug it into my laptop and I can see files and access them.  Any ideas on how to force Windows to re-scan for it and re-recognize the external drive?   Is there something I need to delete or uninstall so that WIndows can go through the discovery process again?

 I am having the same problem. I am very upset. I have had my 1tb my book essentials for a year now and it was working fine until yesterday. I tried calling customer serv ice and they didn’t even have me on file. I registered my tb but they can’t find me in the system and were not helpful at all. I don’t know what to do, all my summer nature photography is stuck on my tb. It doesn’t look to be lighting up all the way in the front and the lock light and dot light under that are both lit. It is humming just fine, I opened it and it dosen’t look to have any damage, so I don’t understand what is going on and I am seeing complaints about this issue all over the internet, but no solutions.

I am seeing a lot of posts on this and they all go up to a week ago so WD must have done something that is causing us problems, or windows did. … but they better figure out how to fix it… keep your eyes on the forums.

Are you swithching between computers with different OS like Windows 7 and XP? You mentioned desktop and laptop are you removeing drive properly everytime?


I’m on windows 7 with my laptop. My uncle is on vista with his desktop. I was not able to detect it on either computer.

I normally just remove my usb cable from my computer before shutting down. Haven’t had any problems with that and I’ve been doing that for a year now.

It only has to be writing to the drive and interrupted once to cause corruption. I use either the safely remove icon to or when I shut down wait until Windows is fully shutdown not just the desktop clearing out. I’ve wondered about this  for a while and don’t know where to findout. Windows 7 and XP both use NTFS but Windows 7 is slightly different I think Vista is like XP there. I ran into this when dual booting Vista and windows 7 beta. I used Acronis disk director to partition and format and I had trouble with the Windows 7 beta and had problems. I reformatted the partition with windows 7 install and didn’t have any more troubles.


I’m not finding it in computer management. It’s not locatable in any parts of my computer. :frowning: I read all the other stuff I could find similar in the forums and none of it was very helpful.

I saw this post a while ago and am not making any recomendation on using it You might do a web search and see if you can find anything similar.


no luck, need free partition software, got one only restores 1 gig