My Book 2TB won't show up on my laptop

Hi I recently got a “My Book Essential 2TB” external hdd and I plugged it into my laptop, which is a brand new laptop I just got, and nothing happens. It can’t be found anywhere: disk management, my computer, nothing. I plugged it into my PC desktop at home and it work right away perfectly -_-. I need this hard drive for use at school with my laptop. Also I tried calling support but they were super busy and would “call me back,” never got that call…Anyone help?

am facing the same problem but  in different way !!! actuall  my essential 1tb external hard drive is not recognized by my pc … but when i tried on another pc it works …

i even deleted my smartware software still it not working in my pc …

when i connect with my usb port its show the password box and after putting it hangs then i have to restart my computer … this problem is with my pc only … when i connected with my office pc it work smoothly.

if you find a solution kindly help me too my mail id :


How is the drive connected to the power source? Are you using a power strip or is the unit connected directly to the power outlet? 

Both situations I plug everything in exactly the same, and yes it is to the wall, not a power strip. Same thing happens every time. Plug into PC-desktop, works perfect and wonders. Plug into laptop, light keeps blinking, nothing happens.