My Book 2TB usb3 data transfer speed issues

Hi

I have a My Book 2TB external harddrive that we’ve used to store all of our family photos and videos. I’ve recently noticed that it takes a lot of time to copy a file from this hard drive to another drive (USB stick or internal drive on my computer). I bought a new harddrive to replace this one and have started transferring our information from the old drive to the new one but it’s taking a lot of time.

Computer Specs
OS - Windows 10
Intel ® Core™ i7 CPU 920 @ 2.67GHZ 2.67GHZ
Ram - 12GB
64 bit OS
IHD - Samsung SSD 840 Pro Series ATA device

This morning I started to move the information and a 3g folder took almost 2 hours to transfer. I started a second folder with approximately 7g and it looks like it’s going to take 5 hours to transfer. When I click the drop down for more details in the copy window it shows that the speed is very erratic. It drops to 0 bytes/s and then increases to up to 5mb/s and then drops back to 0 bytes/s. Each time that the transfer stops my computer makes the disconnect/reconnect hardware sound.

It appears that the transferred data is ok as I can open the files that I transferred this morning. Does anyone have any ideas what could be causing this and if so is there a solution or is this a faulty hard drive.

Any assistance will be greatly appreciated.

Hello,

Have you tried replacing the USB cable? or have you tried on another computer?

I own another WD 3TB external harddrive and it works fine with the same cables that were connected to the original problem drive. I’ve had the newer larger harddrive connected and it hasn’t had any issues. Write and read speeds are fine and it’s working exactly as I would expect it to.

To give an idea of how this effects the harddrive, I right clicked on a large folder full of images and selected properties and it took the harddrive 15mins to estimate how many photos and how many gigs were included in the folder. I did the same on the backed up version of this folder (approximately 6 months old and maybe 70% of the volume of the current folder) and it took 10 - 15 seconds. I can’t find a diagnostic device on WD that allows me to check the harddrive but it feels like it’s stopping and starting. Very odd.