My Book 2TB Mirror Edition Firmware refuses to install


#1

I downloaded the latest firmware version WD_MB_Mirror_1011_1_02.exe from WD website and it fails to install even though it successfully detected the drive (see attached screen shots). I have tried this with drive attached to Win XP, Vista and Windows 7 PCs all with the same result.

http://support.wdc.com/product/download.asp?fid=wdfMyBook_Mirror_H2U&wdc_lang=en


#2

Jan_Shim,

I can’t see the attached file.  Please send me a link or upload to your facebook.

1.  What Firmware do you have now?  I am not sure, but some vendors it may allow you to update only from “certain” released Firmware version to x.

2.  Did you have only 1 My Book 2TB Mirror Edition Firmware connected?

3.  Are there any other USB device connected?  Flash USB or even USB card reader?

Good luck.


#3

From WD’s webpage http://support.wdc.com/product/download.asp?groupid=115&sid=106&lang=en

File Name: WD_MB_Mirror_1011_1_02.zip

File Size: 2.13 MB

Version: Firmware Version 1.011

Publish Date: September, 2008

I pulled the following from Property | Hardware Ids and wondered if the installed firmware is newer than what’s available to download from WD web page. Yes there was only 1 MyBook connected asI own only one of such drive.

USBSTOR\DiskWD______My_Book_________1012
USBSTOR\DiskWD______My_Book_________
USBSTOR\DiskWD______
USBSTOR\WD______My_Book_________1
WD______My_Book_________1
USBSTOR\GenDisk
GenDisk


#4

Jan_Shim,

Somehow you have higher FW version that what is posted that is why it is not posting it.

You have 1.012 FW (according to Property) and Firmware Updter posted on http://support.wdc.com/product/download.asp?groupid=115&sid=106&lang=en is 1.011.

The Firmware Updater can only go up (upgrade) and doesn’t downgrade.

You do not need to upgrade to 1.011 which is actually downgrade.


#5

Thanks. The store who sold me the unit did not even know this when I asked them and probably thought I wasted their time when in fact they wasted my time and effort in find an answer that, in hindsight, was sitting there in front of me.