My Book 2TB Gave and I/O error and is now an Unknown Device?

Hey guys,

I’ve spent the last 14hrs going through various pages on this forum, and googled almost every possible search term I could possible think of in hopes to find a solution for this problem. I’ll try to keep this as organized as organized as possible and provide as much information as I can.

OS:  Windows 7 64bit

Hard drive:  My Book Essentials 2TB - USB 2.0

What occured: I was transfering a group of project files (which added up to 17gb) from one of my WD 1TB My Book (last generation) external drives over to the new one and all was going well until I got an I/O device error from the 2TB My Book. I’ve had this hard drive for almost 4 months without any problems at all.

When I got the I/O device error, I safely ejected the drive, power cycled, and reconnected it (I also disconnected all other external drives to prevent any mixup). This time it wasn’t listed under My Computer but it showed up under Devices and Printers. Instead of showing up as My Book 03 (which is what I called it before) it shows up as My Book 1110. When I right click it, the only options that show up are: Eject, Create Shortcut, Troubleshoot (shows a ! within a yellow triangle), and Properties (pictured below).

Right Click.jpg

If the above does not show, here’s a direct link:  http://img508.imageshack.us/img508/355/rightclick.jpg

Within Computer Management I see the drive show up as (pictured below). There were no helpful option by right clicking any of the two spaces.

Disk 5

Unknown

1862.35 GB

Not Initialized

To the right it says: 1862.36 GB Unallocated

Disk 5.jpg

If the above does not show, here’s a direct link:  http://img14.imageshack.us/img14/5238/disk5.jpg

It doesn’t let me access any of the files within it and I have over 1.5TB worth of files inside this drive.

Things i’ve tried:

  • I’ve tried using over 4 different USB Cables (2 of which work fine with my 2 other 1TB My Books).

  • I’ve tried 3 different power cables from both a power strip and plugged directly into the wall.

  • I’ve used different USB ports from my USB hub as well as directly into the computer.

  • I restarted and shut down the computer as well.

  • I plugged the hard drive into my laptop and another computer and it still shows up only under Devices and  Printers.

  • A number of solutions from these forums including:

 - Installing WD SmartWare Utilities (VCD & Firmware)

 - Installing WD SmartWare Software which I updated software on the drive and directed it towards the files.

 - The above 2 options seem to have worked but nothing really changed. My HD was still only showing under    devices.

  • I tried using the WD SmartWare software but it would only find files from my computers hard drive.

Since trying all of  the above I uninstalled WD SmartWare and now when I plug in the drive I get:

No Driver.jpg

And this is how it looks under my Device Manager:

DManager.jpg

Links on this forum i’ve looked through (that I can remember):

http://community.wdc.com/t5/My-Book-for-PC/Software-shows-on-My-Computer-but-files-don-t/m-p/74946/highlight/true#M3098

http://community.wdc.com/t5/My-Passport-for-PC/Driver-Error-Message-WD-SES-Device-USB-Device/td-p/2852

http://community.wdc.com/t5/My-Book-for-PC/My-Book-1TB-Not-showing-up-and-no-error-msg/td-p/6584

http://community.wdc.com/t5/Other-Externals/Can-t-download-drivers/m-p/15495

I’m currently stumped and running out of hair to pull out…

I’ve got a few files in there which I have yet to backup so I truly want to avoid having to reformat it. I’m also  trying to avoid having to take out the actual hard drive since I don’t want to void my warranty.

Sorry if I forgot to post any other detail but if I did let me know and i’ll post it up.

I truly appreciate any and all help. Thank you.

You don’t want to take the drive out. There is info on the bridge chip which hardware encryts the data, it’s not a standard drive. You sound computer savy this might help http://www.techsupportforum.com/forums/f16/have-you-lost-a-hard-drive-partition-or-files-in-your-computer-194492.html and http://www.cgsecurity.org/wiki/TestDisk_Download good luck.

Joe

1 Like

Hey Joe,

Appreciate the quick response.

I came across a few posts about TestDisk before but never checked it out. Thank you for the helpful link. I’m currently on the step in which its analizing the cylinder. Since it’s a 2TB drive, this might take some time, so i’m gonna leave it over night and see where it’s at in the morning.

Currently at 4/243114: 00%

I’ll update this when it’s done!

Update:

Started running TestDisk on the problamatic 2TB My Book on Sunday, it’s now Tuesday and last I checked it was at something like 204/214413 00%

In other words the drive is too big for this to be completed anytime soon. Today I awoke to my computer being turned off which was most likely due to the storm that was going on outside, even with my backup battery, it still shut off.

As for now i’m gonna run a few more tests from other programs to see if I can possibly retrieve some data from the drive before calling in and seeing if I can get a new one =\