My book 2.0 500g on XP


#1

I have the my book essentials 2.0, 500 gig external hard drive, and have been running it on xp. over time the drive would take longer and longer to recognize. More recently the drive stopped being recongnized by my computer as a letter assigned hard drive.

The most recent instance being after I turn on my computer it hangs at the bios screen, not indefinately mind you, but for a very long time. The same goes for the diagnostics of the bios loading up, and the operating sytem loading. These problems do not occur when the my book is not blugged in on start up.

Once the OS is loaded and I can view all of my programs I have a problem with the actual my book being visable. The drive letter no longer shows up in my computer. Digging a little deeper the device manager does not show the my book under usb controllers but rather shows “usb mass storage device”. A little deeper shows that If I show all hidden devices in device manager I can see two hidden drives under disk drive. One of which is WDC WD800JD-00LSA0, and the other simply marked as WD.

WD allows me to enable disable and change options about it, though the options are already optimal so I haven’t touched them, the other cannot change any options. Both state located at location 0, which is probably why it’s not being read.

I tested a few ideas about the drive to see if it is being identified in any way. Obviously the system recognises it as a large storage space from the usb identification. I tried to see if the drive letter was still assigned by plugging in a jumpdrive, but instead of being assigned the next letter above what is usually assigned to the my book, it was the same letter as what is usually the my book.

The last test I tried was using a “Wetern Digital Data LifeGaurd Diagnostics” tool, that I’m unfamiliar as to how i’ve obtained, but there it shows the WDC WD800JD-00LSA0 name with an odd serial number, shwoinging an 80gb compacity,  and shows it as passed, and even passes the quick and extended tests. The next drive in the list shows as just “(usb)”, showing no serial number, no compacity, and showing “? not available” under where it should show pass for SMART status. It also fails each test before it can begin with the status “cable test::Read dignostics sector error!” Beyond that the tes show only the option to close and has a status at the bottom that read “Cable test failed! Please test the cables.”

I have 4 working usb 2.0 cable that fit the slot available to the my book, but with each one no improvement is made. I’ve scanned the computer for corrupt files, and no files show as corrupt. If there were corrupt files in the my book I could scan and fix the errors, but since I cannot access any files in the my book I’m out of otions.

Are there any ways to access the files within the my book at this stage or are all the files saved to the my book  now gone forever?


#2

I’d like to futher add that I have preformed thorough virus scans, and there are no viruses on my computer.

Also I have checked disk management, and neither the drive letter, nor the my book show under disk managemrnt.


#3

Update*

I was able to access the hard drive yesterday. Immediately after getting the hard drive open I ran scan disc for disk errors. No errors were detected.

Afterwards I checked to see if the drive needed to be defraged. It did not so I left it alone fearing if there was too much movement within the drive it would again become unstable.

After having the drive on for about an hour I began to recieve an OS error stating that thier was a failure to save to the drive, although I was not saving anything to the drive. All files were in tact but were deemed unusable. I could click on pictures, music, clips, and files, but would recieve errors specific to each media exclaiming the file is inaccessable. Also the OS could not generate previews of the files, I did not pay attention to weather or not the correct file sizes were being dispayed but all filenames were still visible.

I attempted safely removing the drive and reconnecting to see if it would reboot the drive and allow it to work. It did allow the drive to work correctly, but as previously the drive became difficult over a short period of time.

When done with the computer for the evening, I did safely remove the drive to prevent any further problems, before shutting the computer off as oposed to letting the drive shut down with the computer. The result was that the my book running lights remained on, I assume meaning the drive continued to run.

I attempted to connect the drive multiple times today, and was not able to access files from the drive, however, the drive now shows with it’s serial number when connected in the device manger under disk drives, and also within the WD diagnostics tool mentioned earlier, and recognizes the compacity at 500gb, but again it shows under the “SMART status” section “? not available”.

Next time I am able to access files on the external drive I will make certain to test the WD Diagnostics tool to see what results I recieve when the drive is funcioning correctly.


#4

I’m having all of the same issues!  And of course Western Digital refuses to help because the drive is out of warranty!


#5

have you take off hard drive and connect PC directly? it seems got weak head. and don’t try more on it. try more will make platter damaged. and don’t do any test on drive. you should full backup files once you can access data.