My Book 1TB, shows up in Disk Utility but not Desktop

I am sorry if this has been addressed elsewhere or if this issue is plainly ignorant… But, I’ve been googling like mad, and I just can’t seem to figure out what to do. So, I am just going to retell the situation in ridiculous detail and hopefully someone can help.

So, I was editing in FCP, and since I didn’t have enough space on my computer to hold the footage, I was working through my 1TB My Book. The harddrive was accidentally knocked over (eep) causing the cord to pop out. After pressing ‘Okay’ to the message about not properly ejecting the disk, I tried plugging it back in. Initially, it didn’t mount. So, I tried again. And then it did mount! So, I continued to edit. A few minutes in, the harddrive disconnected again, but this time it wasn’t because it was unplugged. Since this moment, I have yet to reconnect to the harddrive.

Needless to say, I tried reconnecting many times, but the icon never showed up on the desktop or in the finder. I’ve shut down everything, unplugged everything… All the basic first steps. Didn’t work.

Then, I checked the disk utility. Lo and behold, it is listed in the disk utility. A bunch of options were greyed out and a bunch weren’t. In order to avoid forgetting to mention some, I’ve taken a screen cap. Here it is:

Diskutility.jpg

Anyone know what all of this means? And what are my options? Is the harddrive dead and gone? Or, do I have a chance…?

Thank you in advance.

Hi there, since your drive is seen on disk utility then not everything is lost.

On first aid, click on verify disk. Your Mac will try to see if the drive can still work without reformatting and then will give you the option to repair the disk.

If it fails at the verification or at the repair, then you may need to format the entire drive again on the partition tab.

Hey, PizzaMatrix. Thanks for the response.

Neither verify or repair worked.

If I were to format the drive again, would I lose the information on the drive? If so, how can i transfer the information to another drive if the flawed drive won’t mount?

Reformatting is going to erase the data. To transfer the data you’ll need a recovery software.

Try TestDisk first as it is free and quite powerful, then if it does not work then you can try Disk Warrior, which is a pro tool…

Good luck!

So, after the reformatting, the harddrive should be usable again?

Thank you so much for your advice! You have been very helpful.

Yep, the drive should work again after you format it. But I would check on errors and replace it if happens again.

Any time ^_^

It’s most likely that you corrupted the partition on the drive, so you may also want to make sure that you’re not just pulling the usb cable before safely removing the drive, especially just after copying data over to the drive.  On Macs, you safely remove by dragging the drive icon into the trash can, and waiting for it to fully disappear before disconnecting the drive.