My Book 1TB - Not showing up and no error msg


#1

My computer does not show any new devices when I attach my WD My Book Essential Edition.  My hour glass flickers at times but nothing.  What can I do, does anyone know?


#2

I am going crazy too :frowning:

Two days ago I purchased My Book Elite 1TB.

My XP doesn’t recognize it. I tried with different cables in three other PCs and Laptops: same problem!

Hopefully someone will be smart and nice enough to give us any hints.

rgds,


#3


I have this error as of today. I use USBDeview.exe from http://www.nirsoft.net/utils/usb_devices_view.html which allows to display connected devices in real time. The disk does not show up any more. I tried disconnecting and connecting on various USB-ports (on 1 PC only as of now) and I get a different sound than normally (as with my other disks/devices). I tried removing power and reconnecting. Nothing helped. I tried rebooting once and it connected a single time and not any more. The LED light of the disk is flashing a few times and then turned off. I was looking for help but this post seems to have none at the moment.


#4

I found a solution in my case (for the moment): In USBDeview.exe I disabled and then enabled the device (found when “Options->Display Disconnected Devices” was activated) and then reconnected the drive … voilá … It was there with drive letter !


#5

i have the same [deleted] problem … this happened in my case after the password reseted it self … someone help please