My Book 1230 4 TB drive swap

Hello all,

I recently bought a My Book 1230 4 TB and want to replace the internal WD Green drive with a Red one, because it will be running 24/7.

I know that my warranty will be void and that this procedure is not recommended.

However after replacement, the drive shows up in Windows as My Book 1230, but with 0 KB storage. In drive manager it shows up without partitions and Windows wants to create a partition-table, which fails.

I tried different methods to bring it back to life:

  • I mirrored the old to the new drive 1:1.
  • I partitioned the drive manually and cloned the first partition 1:1.
  • I installed the WES-driver and the WD Quick Formatter on my machine in order to delete and format the new drive according to WD policy.
  • I googled for the PCB to see, if it has a reset-jumper (the PCB has a few jumpers without pins, but I don’t know which is the correct one).

None of the above brought the desired results.

The old Green drive is untouched and it works.

I hope some of you guys can help me.



This process is not supported and I would not recommend it either. Remember that WD External drives usually include encryption and that may cause an issue when swapping internal drives. I have never tried this and i cannot provide any advice because of that. But lets see if another user has tried it and can share some experience on this topic.