MY book 1230 3TB and 4TB Won't recognize by Windows 7 or 10

Tried my 3tb WD my book and my 4tb WD MY book and neither can be recognized in disk management, diskpart, or my computer area of windows 7 or 10. They are both recognized as usb devices in device manager. Neither are recognized by WD drive Utilities as having any storage space and fail SMART Scan. Any ideas?



Make sure the drives are plugged in directly into a wall outlet to discard any power issue.

I did that.

I’ve tried multiple power outlets as well as usb cables.

Hi I’m having similar problems with a 6TB I have a thread also but mine can be available. sometimes shows but can’t open files or will drop out while you working and doesn’t show available I pull power on it for a mintue then plug back in and it registers again, I’ll keep you up to date if I sort mine I’m running windows 10 mines always been updating but you don’t get this update, you might have if not there’s a new version not sure how long available for, I just downloaded last night it’s like a clean install of a upgraded win 10 operating system(allow a couple of hours or more depending internet and computer speeds) so I’m going to try that It’s at / support their link is at bottom of page top banner, It’s a Anniversary Version

found this resolve post in one of the threads in HP forums

The root cause of my 9 days long search for a solution was a malicious program called Setting Manager by AZTEC
Removing it and rebooting the Desktop cured the problem
Now all USB devices, including my Western Digital My Book 1230 are recognized.
Thanks for your hints, support and everything.
This is a “Case Closed” with a happy ending :slight_smile:

there has got to be a hardware issue with these drives as when mine went out 2 weeks ago went to do some changes with cabling shut down tower and everything other drives) shutdown except drive, so plugged into laptop still nothing had to pull power on it repower it for it to show then eject it, pulling the power for a mintue then plug back in has been how I get my machines to recognize it again when it disappears, WD said with mine do RMA once had data restored to where could use it