My backup drive isn't working

Six years ago I bought a My passport 1TB HDD (which has built in password protection software). I ran all the tests (multiple times) that, “data life guard” and “WD drive utilities” had to offer and everything turned out fine.

After making sure everything is ok, I stored my data on it. Then, I kept it in a dry place, and without the possiblity of any mechanical damage. I also made sure that it was sealed properly from air moisture using cling film and plastic bags, well, I did the best I can back then.

The drive was only used in the beginning, during these tests, and while storing the data on it. So relatively it was kept in near “new” condition.

Recently, I connected the drive again to access the data. Now, the first time I connected it, I saw the drive in Computer, and the password prompting window comes out (everything is ok!). I enter the password, and then this clicking sound started to come out, plus indicator light keeps going on and off on the drive. At the same time, I can’t access the data. I disconnected the drive, plugged it back in for a second time, clicking starts immediately, and now, it doesn’t even appear in Computer!

This has been the situation since then. Everytime I connect it, nothing but the clicking sound, and USB connected sound comes from the computer but, nothing else. Sometimes, at first, it appeared as an unrecognized USB device but now, nothing at all. I tried moving the USB cable around to see if it’s properly connected, that’s when this horrifying beeping sound briefly came out of the drive. I never tried that again though!

I tried even giving it gentle hits (when it’s disconnected of course) on the side with my hands, perhaps the arms inside are stuck but, when connected again, it’s nothing but the same. Now, all I’m left with is the clicking sound and nothing on the computer side to show.

It’s worth mentioning that, when I touch the drive while connected, I can feel it spinning.

Perhaps the electric board became faulty from the long “slumber”. But, I’m not the expert here.

Update: When I keep it connected for a while, an empty CD drive icon appears in Computer, and in notifications area a USB device appears.

What do yu believe is the issue with my drive?

If your USB drive becomes unresponsive or you’re unable to format your drive then there are chances that your drive may become RAW or inaccessible. There are various reasons for this issue such as BIOS settings, USB data line, USB interface voltage variability, drive hidden issue or compatibility issue, etc. Data recovery from a faulty or unreadable storage drive is not that challenging if you have the right tools with you such as trustworthy data recovery software. Here, I recommend you to use Stellar Data Recovery Professional Software as it is one of the most reliable & easy to use data recovery software that enables the user to recover their lost or deleted data from corrupted, unresponsive, or accidentally formatted drive and even recover lost partitions of the drive.

Whatever be the reason, the end result is data inaccessibility or data loss.

I will suggest you to check out the below blog to know the best possible ways on “ How to Recover Files After USB Flash Drive Becomes Corrupt or Unresponsive ?”

Hope this will help.

Dear Mikes2. Thank you very much for your answer!

I’m a bit hesitant to invest in a data recovery software, if the drive is password protected (encrypted).
This drive is password protected, using it’s WD built-in software (possibly a driver), as I mentioned in the question above.

I assume that such hard drives are encrypted whether you use a password or not. Worse still, a password was in place.

I hope you can provide me with a name of a good cost-free solution to give it a try anyway, however again, the drive is hardware encrypted.

So instead, I hope there’s a way to identify the problem in order to get it up and running and then, get the data.

Please note that, this is the same computer (same BIOS), and the same operating system (Windows 7), that I used originally when the drive was functional. I also tried different USB sockets, and I only use it’s original cable. Yet, all was futile.

First of all, you don’t need to invest or purchase the data recovery software at the first attempt. You can download the Free version of the software to scan the drive and to check the results. The free version of the software will also allow you to recover up to 1 GB of data.

However, if it is password protected and you are not aware of the password then I suggest you first contact the customer support of the drive and ask them about the password. Maybe there is some kind of generic password about which they can help.

Maybe the USB port is not supplying sufficient current, have you tried using a Y USB cable with a 5V adaptor or another USB2 port (i.e 2 USB ports - but not on a hub). If you don’t have a Y cable try plugging the USB cable into a 5V adaptor and if it stops clicking and you can feel the disks spinning then lack of sufficient current from the USB port may be your problem.