My 500GB MyBook appears to have Died

500GB MyBook combo firewire/USB quit working last night.  It hadn’t been attached to the computer in a week or so.  When I plugged it in to power and firewire, it started to spin up, clicked a few times and stopped completely.  Got the sound from the computer that tells me it was attached, and the lights on the front of the MyBook were all lit solid after doing their usual spining.  Plugging and unplugging several times produced the same result, but eventually, the lights would come on, but no spinning at all.  I tried a different power adapter from another MyBook with the same voltage/wattage and it did try to spin the drive, but with a different pattern of clicking, and it did produce a more persistant effort, trying several time to get the drive spinning before giving up. 

I’m now getting about four or five attempts to spin up the drive.  When I turn it on, all four lights are lit, it clicks seven times, rests, trys again, clicks twice, rests, trys again - this time with all of the lights blinking in their normal circular pattern, then it clicks twice again before coming to rest with only one or two lights lit.  It also sometimes will give the connection signal through the computer speakers a couple of times as it is trying to spin, like it is connecting, disconnecting and then connecting again.

I’m just wondering if I have some sort of power issue with the drive instead of the usual head problem, or if anyone has any ideas/suggestions.


Hi there,

Sorry to say, but it looks like this drive has failed. As you mentioned, you have tried using  a different power adapter and you’re still hearing the clicking noises. it looks like the issue is more related to the drive itself.

I would recommend you contact WD to replace the unit. Click on the link below: