My 3rd Passport 500gig that does not function.....sending ti back AGAIN

I have beein in the IT world professionally since 1999. I know all brands fail as the manufacturing process is never 100% perfect. But I am starting to loose faith at least in this section of WD. I have a side business of landscape photography that I am trying to create a critical backup of my RAW files, and each time I get one of these Passport 500 GB drives it starts clicking on me and dies. Every disk I have in my system is WD. I have 7 other internal drives (3 of which are in a RAID array for my local data redundancy) and 2 large external drives. I have had zero problems from them.

I keep sending back this passport drive. I have tried diffrent cables and diffrent drive ports and even diffrent machines to have it attached to.

This drive didn’t even last for a week. EVERY time I start to get a decent collection for backup on one of these drives, it starts to fail. I dont have this problem with my other drives. I just need a small portable drive for my off site backup.

Frustrated to say the least. Will I ever get a decent copy of one of these drives?


Oh…the symptoms on each of them are that it starts a soft and steady clicking noise like the Actuator Arm is struggling and the drive locks up.

I almost want to ask if there is somthing I am doing wrong, but all my other drive work just fine on my PC using the same cables and USB ports. Even my work drive I use every day which is a smaller version of the drive works ok on my home machine.

If they are a USB powered drives that may be the issue.  Contact customer service and see if you qualify for a power booster cable. It’s Y shaped and uses 2 USB ports.


1 Like

Testing now. I have a Dual A to Mini from one of my work drive. I was suspecting that as well today. I have it plugged in right now. 3 of my drives are in my self powered Drobo unit, but I do have 2 externals and a printer as well as 3 SATA drives internally. I dont have a crazy video card but it is a decent one with an external power input so probably pushing my 500W power supply close to its intended load.

I ran the drive on my work PC all day without incident. I have it plugged in now with the dual cord you suggested and as of yet I have no problems with the extra power afforded by the 2nd USB A plug. If by this evening I am still getting no clicking, I will have my problem resolved.

I will give customer service a call and get that cable.

Thanks for the heads up.