Multiple Time Machine Backups are not working since upgrade to OS5 (Bug)

Hi WD Community,
I recently upgraded to OS5 and I really regret it.
Before the upgrade, the Backup for three Macs worked flawless. Now the Backup only works for one Mac at the same time. I noticed that defining the amount of storage only gets stored for one Backup. And only this Backup works properly afterwards. The other stay on unlimited storage and won’t work.

For me thats clearly a bug. Because when I restrict another Backup - the first stops working and the second one works instead. Same with the third one…

So if theres a workaround please tell me. If not please release an update.

thank you


Are you using TimeMachine through AFP or SMB?
SMB access to TimeMachineBackup share seems broken with v5.09.115. It stopped working at all with all three Macs at home (Catalina or Big Sur either). Removing and adding again the TM share into the preference panel lead to Time Machine working again as after failing to connect via SMB first another login window was offered and enable it via AFP.

1 Like

try one timemachine backup per share as a test
that may work better ?

and there is a size adjustment for how much of the share to use for time machine backups

As part of the weird behaviour, the TimeMachineBackup share shows up in the web app (and mobile) app despite its web access being disabled.

Other shares set as public with no web access do not show up.

I have put the screenshots below.

Latest Update installed, still no changes nor does Timemachine work on more than one Mac. (every mac has a different share)

Multiple Timemachine Backups was one major reason, why I bought this device from WD.

Please help me with a workaround or release an update which works.

Before OS 5 everything worked like charm. You cannot just release an update which makes stuff for your clients worse. Update should improve, or am I wrong??

1 Like

I have the same issue: 4 Macs in the house, and I want each of them to use Time Machine to back up to my new (OS5) PR4100. And I want each of those backups done on a share of its own … that is, one share per Mac.

But the PR4100’s admin software seems flawed: I can enable share “A” as a TM destination, for use by Mac A, and get its TM backups fully working. Then I go to the admin page of the PR4100 and set a max backup size for share B, to enable that share. I set up Time Machine on Mac B to use share B, and it all seems great … EXCEPT that (maybe after a few hours) Mac A can no longer do backups to share A any more - it fails with an error message on Mac A saying that its Time Machine disk (share A) does not have the necessary capabilities! (Grrrrr!).

From there … if I go back to the PR4100’s admin page and (again) set the max size to use for TimeMachine on share A … well, Mac A can again back up to it - resuming use of the backup file it had started there. BUT (in true whack-a-mole style), that has disabled TM access to share B, and made share A the ONLY one usable for backups.

I saw a note on some discussion forum that said the trick was to be sure to let each Mac get all the way to having completed its first full TM backup (the slow one, which can take days) - and that then it would be safe to tell the PR4100 to enable TM on a different share, and get things going with that one … one Mac at a time. However, I tried that, in various combinations & variations for several weeks … and could never convince the PR4100 to keep more than one share at a time operable as a destination for TM backups.

I also took a look “under the covers”, using ssh to login to the PR4100 and look at the relevant configuration file. Sure enough, the file that specifies the set of shares, with a block of details for each share, gets an extra set of details (about 6-10 lines worth) for whichever share is the most recent one to have been enabled as a TM destination. And using the PR4100 web admin console to enable a different share adds the desired set of config options to that share, but (and here’s the BUG) … it, at the same time, REMOVES the lines that enable time machine access from all other shares.

tl;dr: Enabling any given share for use as a destination for Time Machine backups actively REMOVES the enabling configuration details for all OTHER shares.

So far, the only work-around I’ve found is to have all of my Macs use the SAME share on the PR4100 for their Time Machine backups. There’s no collision (assuming, I guess, that each Mac has a different host name), but it’s not ideal, either administratively or from a security “best practices” perspective: If one Mac were to be compromised (say, by a ransomware attack), the attackers would have access to read/destroy the backups for ALL of my Macs. :exploding_head:

1 Like

Looks like no one got a satisfactory answer to this issue, and I have had the same problem. Prior to upgrading the OS, I had two Macs backing up to separate shares, worked well for many months. Now it seems like only one share can be configured for Time Machine backups - if you go back to configure a different share, the first one no longer works.

If anyone has learned anything new about this in the past month, I’d love to know about it. Thanks.

1 Like