Multiple Public,Smartware and TimeMachineBackup folders

I’m using 0 TB EX4 with two 4 TB WD Green and two 3 Tb WD Green hard drives.Two days ago suddenly two of them began continously blinking showing an error,may be a bad sector.So I took the drives out,checked them with my Pc’s check disk and than put tham back…The blinking was over but after that I have hundereds of Public,Smartware and TimeMachineBackup folders and unable to delete them…Need help…
Regards

We have passed along this information to WD.

Regards,

Thanks…I began using a traditional method to get rid of this situation…Backing up all the four hard disks,after that formatting them,restoring EX4 to factory defaults and having a clean EX4…Long way to go…

No useful info on your issue, but you should be using reds not greens.

I am here looking for a fix for this issue to0.

Should I just contact WD?

Is there no known easy fix?

When it happened to me (64 copies of each share, but actually the same folder shared 64 times) it was fixed by a factory reset. No data loss.

2 Likes

Naf623 wrote:

When it happened to me (64 copies of each share, but actually the same folder shared 64 times) it was fixed by a factory reset. No data loss.

Thank you so much Naf623, I had considered a reset but was too nervous to try.

I had well over 100 of each public folder and now, after a reset \i am down to only one public folder. On the dashboard it tells me that i have all 4 drives. The capacity tells me how much space is being used, the drives are all listed as healthy, but I can only access the information on one drive.

I have tried setting up new public shares with the WD Dashboard and with Twonky (as much as I despise using Twonky) but I just haven’t been able to create public folders that access the other 3 drives… What have I done wrong???

I’m not certain what you mean? If the shares you had are not visible, try recreating them exactly as they were; same name, location, capitalisation etc.

I have found the problem but have no idea about how to solve it.

after the reset my EX4 has set up the drive file paths:

  • Volume_1/Public
  • Volume_2/Public
  • Volume_3/Public
  • Volume_4/Public

When they should be:

  • Volume_1/Public
  • Volume_2/Public_2
  • Volume_3/Public_3
  • Volume_4/Public_4

Because I cant have more than one share named "Public’’ I can only use one volume at a time.

i do not have access to any Linux anything… is there any other way to access the drives to re-name the Public shares?

Or

Is there a way I can get the EX4 to do it? can I take them all out, put them in one at a time resetting or rebuilding the data base between each drive insert?

It is purely a media server for us, looking at the DLNA media count on the WD dashboard thee are thousands of songs, tens of thousands of pictures and a heap of videos… I  would hate to have to reformat and start again :frowning:

Hi,

WD My Cloud EX4, 

I’ve got the same problem. At the end I’ve got 256 Public, TimeMachineBackup and Smartware folders each! In total 768 folders+3 mine :). Deleting 1 folder takes forever!

It started after I replaced my drive with a bigger one:

  1. Initially had 2 disks (500GB+500GB) JBOD separate folders/volumes

  2. shutdown NAS

  3. took out HDD from first bay (that had Public, TimeMachineBackup and Smartware folders) and replaced with a new HDD (2GB)

  4. turned off NAS, Changed RAID to JBOD separate folders - it formatted the new HDD

After that it started blinking on both volumes and keep creating the folders. See screenshot below…

I think it was my fault for doing this. But I didn’t know how to replace existing HDD with a bigger HDD in case of JBOD configuration.

Will try the Reset :confounded:

Reset of the NAS helped. All dummy shares have gone.

Steps: Open Web console -> Settings -> Utilities ->System Restore (Restore to Default) button.

Worked like a charm!

Absolutely diabolical. This thread is now almost 4 years old and yet my new WD PR4100 is doing exactly the same thing as described above. I have over 4000! duplicated share folders and having done the reset mentioned above, it removed the excess ‘Public’ folders, but I still have thousands of SmartWare and TimeMachineBackup shares.

Surely it does not take 4 plus years to workout where there is a firmware bug and fix it. Getting customers to do multiple resets to work around defective software is not an appropriate solution. GET A FIX ROLLED OUT!!!

Same thing – tried restore System Only Default – no good.

This is stupid. There should be a fix – I WILL NEVER NEED 3000 PUBLIC DRIVES!