Multiple drives over a powered-hub onto extender USB port on WDMC

Recently bought a WDMC 3.0TB and just about set it up - when I connect an external hard drive to the USB port, it works just fine (I can see the share created and can access content, etc.). I am also able to get the same if I connected a powered USB Hub into the USB port on WDMC and connected my external hard drive into the hub. However, the trouble begins when I get a second hard drive onto the powered hub - the dashboard pops up an error message initially “USB internal server error (400255)”, after a minute or so the second hard drive actually gets recognised and I can see it on the USB menu top right of the dashboard and then within a few moments the Media scanning status shows ERROR and the WDMC goes inaccessible. I then cannot reach the dashboard, can neither access my mapped drives on my PC, can neither access the WDMC over my iphone app.

Note -

  1. The second hard drive itself is not an issue - these are both individually accessible i.e. if I individually plug either of my two hard drives and reboot, WDMC is all fine and shows the additional share.

  2. I have tried booting with the hub and 2 hard drives plugged in, and also tried booting first and then plugged in the hub with 2 hard drives connected - I run into the same issue.

  3. The 2 drives I am trying to connect are (i) 500GB Seagate Freeagent Go (ii) 500 GB WD My Passport

I have seen another thread with a similar error message but in that case even 1 hard-drive wasn’t working up and that thread never got to a resolution -

And another one where the problem occurred with one hard drive and only upon reboot, again no resolution -

Any suggestions anyone?

 I just don’t think that WD allowed for more than one drive to be plugged in.

Hi - I am absolutely certain I have noted some posts on community indicating they have got multiple drive setup working fine over a powered hub and with individual drives showing up as individual shares :frowning:

try the following… 

Use SSH to monitor the process…

  1. plug each individually and turn off media sharing for each of the drives

  2. then when you are ready to plug the second one while the first one is still plugged in

  3. attach the second usb drive

If you notice a frenzy of activities, kill off the following two process

killall wdnotifier

killall wdmcserver

you can restart them again using

/etc/init.d/wdnotifierd start

/etc/init.d/wdmcserverd start

tell me how it turns out…