.MTS file association in WD 2GO (Android)

Hi, just got my WD Mybook Live 2TB, everything is set up and working well remotely.  My only question is regarding directly opening (streaming) .MTS video files from within WD 2GO on Android devices.

I have mobo player that can play .MTS (AVCHD) installed on all of my android devices (Nexus 7, Galaxy S2 & S3) .  However, when I browse my shared video’s folder on my Mybook Live, from within WD 2GO on any of my android devices, and try to open any .MTS file, a message appears telling me that I need to download a suitable app from the play store in order to open the file.  I have tried installing a couple of other video player apps, and tried re-installing, one by one, and can confirm that they can play .MTS files that have been downloaded to the Android phone, or tablet, but I cannot open them (stream them) from within WD 2GO.  My only option is to choose the “Save As” option, and then download the file completely, and open it from within MoboPlayer.

I don’t believe the problem is to do with normal file association attributes, because an .MTS file opens fine with any capable video player, but only if the file has been downloaded.  However, once again, from within WD 2GO, there seems to be no association with any app for .MTS files.

Any ideas ? - Surely I’m not the only one who has encountered this issue ? - Any help would be greatly appreciated !

Thanks in anticipation,



Is this happening with any files or just the .MTS?

Have you tried  using a different app?

I am having the exact same issue

Keith_1956 wrote:

I am having the exact same issue

Then why don’t you answer the exact same questions?