MtCloud App not connecting to drive


#1

I have two MyCloud drives. I have the MyCloud app installed on my Android phone. I have connected to both drives for years.

Yesterday, I found that trying to access one of the drives just left the app continually waiting to connect. I gave up waiting. I disconnected from the device, and then tried reconnecting. The password was accepted, and the wait restarted. I noticed that each time I tried to re-connect, I could see another ‘device’ being added to the list of devices associated with my user in the Dashboard. I deleted them all, and tried again. Each time, the device would show as connected, but the wait continued.

All other access as a file and media server continued normally. Access to the other drive, using the same app, continued normally.

So I did a reboot from the Dashboard. That took an unusually long time, and the ‘Scan’ field showed ‘Error’ for some time. It eventually settled down, and the front LED turned green (my blue is burnt out, so it’s now configured to show green for normal operation).

Once reboot had finally completed, I was able to connect with the app again.

So, if you have trouble with the Mycloud App simply hanging up trying to connect to your device, try rebooting it. I know it’s the obvious first step, but the otherwise normal behaviour had me fooled for a while.