MPEG4/AVC only plays indirectly? Explanation?

MPEG4/AVC (exact mediainfo below) files do not play via Networkshare, but do play fine through a non-transcoding Mediaserver. How can this be? I thought either the WD TV Live understands a format or it does not?

The other day I was trying to play movies taken with a new Sony Powershot Camera. I uploaded the pictures to my NAS, which runs Twonky UPnP Mediaserver v6. However, since it takes a while for the Mediaserver to recognize new files, I accessed the folder through the network share, but the files would not play (just a black screen for a few seconds per file, but not the message that the format is incomprehensible!). A day later, I tried to play them through the Mediaserver and to my surprise it worked just fine. I know that Twonky Mediaserver v6 can transcode in principle, but the feature is greyed, according to the NAS manufacturer because my specific NAS model has a too weak processor to do this (sounds very reasonable).

So why do they play via the server, but not through the shared network folder? The movie files exist only once on the NAS, and playing other files directly through network share (such as large iso files) works just fine for me.

Here is the mediainfo output for one of the videos:

Complete name : /mediafolder/MVI_4522.MOV
Format : MPEG-4
Format profile : QuickTime
Codec ID : qt  
File size : 55.3 MiB
Duration : 19s 300ms
Overall bit rate : 24.0 Mbps
Encoded date : UTC 2011-04-24 07:41:36
Tagged date : UTC 2011-04-24 07:41:36

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Baseline@L4.1
Format settings, CABAC : No
Format settings, ReFrames : 1 frame
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 19s 300ms
Bit rate mode : Variable
Bit rate : 23.3 Mbps
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 30.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.844
Stream size : 53.7 MiB (97%)
Language : English
Encoded date : UTC 2011-04-24 07:41:36
Tagged date : UTC 2011-04-24 07:41:36
Color primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics : BT.709-5, BT.1361
Matrix coefficients : BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M

ID : 2
Format : PCM
Format settings, Endianness : Little
Format settings, Sign : Signed
Codec ID : sowt
Duration : 19s 300ms
Bit rate mode : Constant
Bit rate : 705.6 Kbps
Channel(s) : 1 channel
Sampling rate : 44.1 KHz
Bit depth : 16 bits
Stream size : 1.62 MiB (3%)
Language : English
Encoded date : UTC 2011-04-24 07:41:36
Tagged date : UTC 2011-04-24 07:41:36

Have you tried playing them from an attached disc? 

I placed the files on a small USB stick and WD TV was unable to play them. Unlike through the network share, I get a proper error message that the file format is unknown.

The files still play on the WD TV Live if accessed through the DLNA Media Server. Weird.

Could it have to do with the extension .MOV somehow?