Mp4 videos pause over DLNA

I just recently received my My Cloud and after fixing the incompatibility I was getting from Streaming via DLNA to my Sharp Aquos Tv, I have found that Mpeg2 and Mp4 are acceptable options to my TV.

I converted all of my movies to MP4, but run into an issue now where after about an hour of play time (sometimes 1:07, 1:08, 1:14) the movie with freeze and the only way to get it to do anything is to exit the movie and try again, but they NEVER go any further than the ~1 hour mark. The Mpeg format works just fine, except my tv wont allow any kind of playback controls with it. I like being able to pause my movies so I would like to get the MP4 version working. Any help would be appreciated.

How are the movies being streamed, over wired Ethernet or over Wi-Fi?

If one does a Google search for “Sharp Aquos Tv dlna freezes” they’ll see others having the same problem with other streaming media server devices.

For starters one can check the Twonky Media Server settings (http://[mycloudname]:9000) and ensure the proper Media Receiver (Sharp AQUOS TV) is selected under the Sharing > Media Receivers section for your Sharp Aquos TV.

If one has their TV connected via wireless, if possible try connecting the TV via Ethernet cable instead and see if the problem persists.

Also check with Sharp to see if there is an update to that model of TV that addresses the Sharp Aquos DLNA client program/software.

You might also try streaming the film to some other device; an Android tablet running Kodi, for instance. This might help determine if f it’s a problem with Twonky, or the TV.

But from Bennor’s investigation, it may be the TV…

Hey, thanks for the responses. Twonky is setup as Sharp Aquos and it is connected via Ethernet.

I tried multiple other formats of encoding under the Mp4 package yesterday and none of them would even list on screen… So it looks like I’ll be calling Sharp this afternoon. Thanks.

If someone streams from any device to any device wirelessly, that can be a problem; especially when the devices are far apart or too far from a router. The freezing could occur with the wireless signal may be OK most of the time, but the strength of the signal varies from time to time, and if too weak for a moment the stream can stop and “freeze”.

I do not have freezing problems because either my devices are all to network, or in case of mobile devices, my wireless signal is good all around our house, thanks to some range extenders in the right places. I always stream on the (faster) 5G signal, but it has to be a strong one.

That isn’t an issue as my tv is hooked directly to the router, as well as the cloud. The total distance between all three items might be 5 feet. Plus, it locking up at the same time consistently points a completely separate issue. Every movie encoded in Mp4 with the x264 video codec freezes at the same relative time (within 1 minute). So movie A will always freeze between 1:04 and 1:06 (+/- 1min from 1:05), movie 2 is 1:05 - 1:07, movie three, 1:14 - 1:16. All of the movies I have encoded in mpeg2 with the mpeg2video codec works flawlessly, I just don’t have the ability to pause, fast forward, rewind, etc. any of my movies. Which is annoying when watching a movie and a kid wakes up and now I’ve missed 20 minutes of the plot.

Anyone have experience using PLEX instead of Twonky as your media server? Or switching the Minidlna?

Have you tried watching the MP4 on any other player, ideally trying both both media server and file server, to help pin it down to encoding, media server or TV playback. If it works via DLNA on another device, it’s probably the TV. If it fails via DLNA on another device, it’s probably the encoding or the DLNA server. If it fails using a file server access, it’s probably the encoding.

I am currently experiencing the same problems streaming videos to my wired smart TV. Partly through the video it stops playing and queue’s up the next video from the file library. I have tried streaming directly to my wired smart tv and through my wireless smart bluray player and experience the same problem.

That suggests an encoding or server problem.

I’d try confirming your test using a ‘decent’ media player, such as VLC or Kodi, running on an Android or other device (or even Windows MediaPlayer accessing the file server from a PC); commercial players on ‘Smart’ TVs and Blu-Ray players, etc. can be a bit temperamental, IME. Are they from the same manufacturer?