mp4 video will not show up on Sharp Aquos TV

I am hoping someone else has seen this issue and can help me out.  I just set up my WD My Cloud 4TB drive and loaded some movies onto it.  When I connected to it via my Sharp Aquos TV, none of the files showed up.

I saw a posting that gave an xml profile for the Twonky server that I loaded in (I’m glad I understand how xml and ssh works and was able to figure out how to make the change in the Twonky file) and was able to get .avi files to show up and play, but still no .mp4.

Here is the link to the message I got the .xml info from:

http://community.wd.com/t5/WD-My-Cloud/Video-file-playback-on-Sharp-Aquos/td-p/665157

I have tried to get onto the Twonky message board, at http://community.twonky.com/twonky but it redirects to the old Twonky message board and it seems to only contain messages from back in 2013.

If anyone can please help me with the correct .xml code to get the .mp4 streaming to my Sharp Aquos TV to work, I would greatly appreciate it.

v/r

Craig B.

Hello,

Check with Sharp support to see if the TV supports .mp4 over the network.

Are you able to play those files from a different TV?

Sorry I did not clarify it up front, but before I got the My Cloud drive I was able to stream to the same TV via a computer running windows media player as my streaming server and all my videos (to include the .mp4 files) played just fine.

So basically that narrows it down to the Twonky server.

Again, any help in resolving this issue is greatly appreciated.

No, because your PC was most likely transcoding the mp4s, so your TV doesn’t care what extension the file is because your PC is doing all the decoding.

The My Cloud does not transcode, so you still need to check to see if your TV suppports mp4 natively over the network.

According to the owner’s manual, here are the formats supported by my TV, which is a model# LC-60LE650U Sharp Aquos TV:

Video Formats.jpg

According to this, it supports mp4 as well as avi, which the original .xml file did not support either and now that I made the changes mentioned in my original post, the avi files work, but still no mp4.

This again leads me to believe it has to do with the Twonky server.  Maybe I am wrong, but that seems to be where my troubleshooting is leading me.

I am at a complete loss here, so I certainly appreciate any assistance you can provide.

Yes, but what does it say above that?

Answer: USB Device Compatiblity

Which means those file types are supported if you connect a USB device (HDD or Thumbdrive)

If you look next to that it shows:

LC-60LE650U Sharp Aquos TV_DLNA.jpg

But then under that it shows:

LC-60LE650U Sharp Aquos TV_DLNA2.jpg

The issue is with your TV not the My Cloud or Twonky.

Also, I too have a Sharp Aquos (47 inch) and from memory, because I use other devices to stream files, I believe that there are limitations on all those file types.

1 Like

Ahh, not sure how i missed that.  I appreaciate you pointing that out and can see I was wrong in my assessment.  I guess I will have to covert my videos to avi or something more compatible.

Thanks for the help!