mp4 audio not working afer updating to 1.06.42_B

mp4 audio isn’t working on all videos with mp4 aac audio and worked fine for me before when i was at firmware    If I go to settings and set it to stereo then I get stereo audio not 5.1 surround sound like before.  I also tried

using mkv merge and convert the file to mkv and then use a program called audio converter to demux found on this link


Well after i discovered this i thought it was a permanent solution but the program only works sometimes hardly at all.

I looked on the forum and there is  a lot of people having some problems regarding this issue and was

wondering why hasn’t there been a fix considering all the updated firmware releases???  and please can i have some

feedback on this audio converting software it only worked for me with 1 video.  Are people  encountering problems

like getting the software to actually work???

dirk_diggler wrote:
was wondering why hasn’t there been a fix considering all the updated firmware releases???

Because none of the people reporting this bug bothered to upload some demo files so this could be verified? Also, 1.06.42 is deprecated, you should use 1.06.43 or 1.06.15.

thanks for your reply …  how do you get a demo file can you explain it to me in detail not sure where to go to do that…  and yes ok i can try the new firmware 1.06.43

I was attempting to download 1.06.43_V and my western digital media player wasn’t recognizing the software when I put

my usb drive in the usb slot…  Then I noticed that I have the western digital live plus model number WDBABX0000NBK.


does the 1.06.43_V work for my player because I thought it has to be the right model number when you go to the

downloading page before you download the firmware???..

here is the log i think i did it right using mediainfo hope this helps you figure out the fix

Complete name                    : 1080P.mp4
Format                           : MPEG-4
Format profile                   : Base Media
Codec ID                         : isom
File size                        : 1.55 GiB
Duration                         : 1h 54mn
Overall bit rate                 : 1947 Kbps
Encoded date                     : UTC 2012-08-26 07:47:17
Tagged date                      : UTC 2012-08-26 07:47:17

Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L4.0
Format settings, CABAC           : Yes
Format settings, ReFrames        : 5 frames
Codec ID                         : avc1
Duration                         : 1h 54mn
Bit rate mode                    : Variable
Bit rate                         : 1847 Kbps
Maximum bit rate                 : 17.9 Mbps
Width                            : 1912 pixels
Height                           : 792 pixels
Display aspect ratio             : 2.414
Frame rate mode                  : Constant
Frame rate                       : 25.000 fps
Colorimetry                      : 4:2:0
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.049
Stream size                      : 1.47 GiB (95%)
Writing library                  : x264 core 125 r2200 999b753
Encoding settings                : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=9 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=2pass / mbtree=1 / bitrate=1847 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Encoded date                     : UTC 2012-08-26 07:47:17
Tagged date                      : UTC 2012-08-26 07:51:25

Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format version                   : Version 4
Format profile                   : LC
Format settings, SBR             : No
Codec ID                         : 40
Duration                         : 1h 54mn
Bit rate mode                    : Variable
Bit rate                         : 96.0 Kbps
Maximum bit rate                 : 135 Kbps
Channel(s)                       : 2 channels
Channel positions                : L R
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Stream size                      : 78.4 MiB (5%)
Language                         : English
Encoded date                     : UTC 2012-08-26 07:51:21
Tagged date                      : UTC 2012-08-26 07:51:25

Yeah, sorry, my bad. I forgot that WD did not harmonize the firmware numbers between Live and Live Plus so yes, you’re on the current firmware. Judging from the Mediainfo output I can’t see why the file should not play back.  To upload a demo download MP4box and MyMP4Box GUI or Yamb and use edit > split to extract a 2 min clip that you can upload to Sendspace or Mediafire.

thank you for your reply again,

the video playback is fine but the audio displays 1/1: English AAC(digital) when you click audio channel and there is

no sound Outputting from my 5.1 surround .  This digital sound was working fine before I updated to 1.06.42_B.  Now I have to go manually to settings>audio/video>audio output - and set it to stereo.   That file should be playing in surround sound no problem because it was working flawlessly before with 1.03.49_B.  Another person had this problem on this forum and here is the link and nothing was done about it just saying…

If more than one people are having this problem will there be a fix in the next future firmware update???

a second person had this problem on this forum and I tried the procedure and it worked for only one movie for me  but it depends on if the software wants to work but it doesn’t . here is the link to the so called solution and Im not trying to put down the support from Western digital but I just want a permanent solution here guys…

Note: It was mentioned I shouldn’t roll back the firmware to the old one earlier than 1.05. or I’ll brake the western digital box…

It’s an old post and I just don’t know, how the current firmwares do. But if a preivous worked for you, why would you consider muxing to ac3 an alternative? In that case you should go back to the last firmware that worked.

Thank you for your reply

when I was at 1.03.49_B there were certain issues I had with the western digital unit  so  I was thinking of upgrading to a latter firmware (have in mind the aac audio was not an issue then) so when I upgraded the firmware to 1.06.42_B the previous issues I had were fixed but now aac was an issue , do you know what I mean its like a toss up for me which problem should I deal with one or the other now.(the other issue in 1.03.49_B was I had to use a lot of mkv merging to get playback to work in the western digital player) now I don’t but it doesn’t matter  because I have an audio issue now which in my mind is a little worse than the previous.

the reason why I was muxing the file to get ac3 is because one of the movies worked for me according to a solution on an  old post using popcorn audio converter but that was for only one movie not the rest of them

Can I roll back from 1.06.42_B to 1.03.49_B or will I break the western digital player as mentioned ???

  I don’t have any other alternatives other than be patient for a newer firmware that fixes my aac audio issue or unless you have another software in mind that works other than popcorn audio converter

thanks for your time