Moving files?

Hi,

How to move files from My Cloud EX2 to My Book Duo ?
I’ve tried many times, everytime i copy/move it always creating a zip type of file.
And everytime i make a transfer, it always make my C Drive storage decrease until no storage on C Drive.

Thank you in advance.
Sorry for my English.

Yes. I know what you mean. A deficiency of the design of the WD NASs. I’ve done it so one NAS copies to the other without the intervention of the computer, but I’ve use the fact that it’s possible to access the underlying operating system and directly use Linux commands and program to mount a SMB network share on the target NAS and then use mv, cp and/or rsync to copy or synchronise files from one NAS to the other.

This is what did to mount a network share from a My Cloud NAS on a DL4100, but here the DL4100 NAS has direct access to the files on the My Cloud NAS and I can exchange files directly from one NAS to the other without the data being transferred touching the computer.

Now, what I can do is if there is a massive amount of data to copy then I can create a background job and disconnect the job from the console so when I logout the job carries on going until an error halts the job or the job completes.

Example:

root@ZEUS HD_a2 # mkdir /m
root@ZEUS HD_a2 # mkdir /m/nas
root@ZEUS / # mount -t cifs //172.16.0.148/AV_media /m/nas -o username=myron,password=NotTelling

Once the file system on the destination NAS is mounted to /m/nas then it’s as simple as copying files and directories from one directory to another.

I figured this out because I didn’t want to tie-up a computer for several hours copying over loads of files.

Would be nice if WD built this facility into the UI. I have asked in the ideas forum. I just need everyone to say yes to it.

Hi Myron,

Thanks for your response.

I’m a newbie in this NAS storage. I’m using Windows 10.

Do you mind to explain more detailed ?

I’m really don’t understand the complex explaination.

Thank you.

Right… This may take some time. It’s because what you would need to do does not involve Windows 10. You would be working with the Linux operating system and the computer you’ll be using would simply be used to access the NAS’s web-based dashboard and also you’ll need a SSH Telnet client. Find a program called PuTTY, download it and install it. you’ll need it.

I can see I’ll be writing a tutorial here. When I learned how to do this it took a bit of time, but then it simply boiled down to just a few commands issued directly to the Western Digital NAS and then I just let the NASs get on with it.

Why, oh WHY?! Western Digital omitted NAS to network share synchronisation is absolutely beyond me. It would be one of the best features available.

I’m writing a note to myself here as well as others, if using rsync then it would work better if a still-in-support NAS and and newer NASis used to co-ordinate file and directory synchronisation as the newer NASs have a newer version of rsync which apparently can correctly handle unicode characters. (Non english letters.)

So, to help me and others, on a scale of 1 to 10 with 10 being expert and 1 being “HELP! I know nothing”, where would you place your skill and knowledge?

Do you know what SSH is?
Do you know what Telnet is?
Have you worked with the command prompt on Windows 10?

What is your skill and knowledge like. It’ll help me and others who will try and help to provide the right level of information.

Really Myron? You’re a pretty technical guy and should know better than this… this is clearly an issue (and a long standing one at that) with the OS (with most OS’s actually) and not the drive - you’d have the same behavior regardless of what NAS you used.

That being said, having a menu option of some kind in the UI to allow direct file transfers would certainly be useful for many folks - you should open a thread about this in the idea boards if you haven’t already- the development folks do actually read them.

I don’t know anything about NAS.

I’ve downloaded PuTTY. What is the next step ?

Thank you.

@Great_Scott, I’m being honest. If someone has a different NAS that’s not a DL4100 then there should be options to create a job to on demand or on schedule, synchronise a network share with another network share or directory within a network share on another server that can be anything else that can be talked to using the SMB protocol.

I want to regularly synchronise several network shares from a DL4100 to a MyBookLive Duo. There is nothing on the DL4100’s UI dashboard that can do this do I have to dive into the DL4100’s operating system, mount a share on the MBLD as a directory on the DL4100 and then using rsync with appropriate parameters so one NAS synchronises with the other directly without involving a computer.

That is a missing killer feature that’s somehow been omitted from Cloud OS3.

If I was to look for features for a NAS for small business use or serious home use, any NAS that could do as I’ve just described would be a prime candidate of purchase.

So, one may have a DL4100 NAS as a primary server, but might wish to set-up a computer with FreeNAS, appropriatly configure it and set-up overnight jobs on the DL4100 to synchronise to the FreeNAS server. If the DL4100 dies for any reason then the FreeNAS server could be used to take the load.

I thought long and hard before I wrote my comment. I believe it to be true.

The DL4100 is a really nice NAS and does it’s job really well. I’m quite impressed . It’s just that someone missed out on implementing a seriously useful feature.

It’s something that could be rectified by a future update? Nudge… Nudge… Wink… Wink…

I think I did open such a thread a while back. Will check.

Thanks for clearing up what you were saying and sorry if my response was kind of harsh (it wasn’t by design) …Your suggestion is good, although I’ve never personally seen this feature on any NAS, WD or not. The Safepoint Backup feature does accomplish a lot of this, although not in the same way you are suggesting.

Anyway… back on topic… Based on the OP by @dannywir:

the main issue he is having is that when he opens two windows explorer windows and copies a file from the EX2 to the My Book Duo (which is a DAS drive connected to the USB port on his computer) the files copy first to the local C drive - he is running out of space on the C drive which is interrupting the process. This is basic Windows behavior and isn’t something we have any control over.

As you suggested, he could SSH into the drive and initialize the transfer directly from the drive which would prevent the above behavior but is pretty complex for the average user. He could also simply connect the My Cloud Duo directly to the USB port on the back of the EX2 and create a Safepoint which would avoid the use of the computer as an intermediary and should accomplish what he’s trying to do (back up the EX2).

1 Like

… but what Safepoint can’t so is synchronise some network shares to similar shares on one NAS and another set ot network shares to a second NAS and so on…

Safepoont is way to too restrictive.

Hi all (Great_Scott and Myon),

Can you please explain in simple way ?
I don’t understand the complex explaination.

Thank you.

@dannywir - Follow the instructions in http://support.wdc.com/KnowledgeBase/answer.aspx?ID=10428

Hi Great_Scott,

My purpose is moving all My Cloud EX2 and combine from all my External HDD.
Because few months ago, I moved files/videos to My Cloud EX2 and now what i want is moving all files back to my PC.
So I can arrange them. Can My Cloud EX2 act like usual USB Ext HDD ?

Thank you.

By-and-large the EX2 will act similarly to a regular USB drive. If you map a drive letter in Windows it appears as a normal drive you can drag and drop files to - once you have done this you can use the Safepoint feature to keep a backup of the data you are storing on the EX2 (remember you should at a minimum always have 2 copies of important files on two physical locations - the RAID on the EX2 is not a substitute for a backup).

Keep in mind that Windows WILL first make a copy to the C drive when moving files onto the EX2, so if you have very little space on C you’ll run into those errors you mentioned.

I’ve not forgotten. Vary soon I’m going to synchronise a very large network share of about 290Gb from the DL4100 I’ve got with a MyBook Duo, but I’ll be using the DL NAS to do the synchronisation because rsync on it is a newer version.

When I do this I’ll document what I do stop by step and then put this on the forum. It’s going to take a short while because where a number of people will assume that others know a bit about Linux and gloss over detail, I’ll try not gloss over the detail.

Actually, once learned the procedure turns out to be very easy…

Watch this space . . . :slight_smile:

@dannywir, I have to make a very book OOPS at this point. I need to read things carefully. You have a MyBook Duo and not a MyBook Live Duo. So sorry about this as I realise I was barking up the wrong tree. I will now go and bark up the right tree. I eat humble pie.

On the EX2 manual, see page 68:
http://www.wdc.com/wdproducts/library/UM/ENG/4779-705129.pdf#page=73

I just clicked the MyBook Duo is a USB only external drive which is RAID1 capable.

I also understand that the My Cloud EX2 has no actual safepoint functionality.

Create a back-up job for each network share to then back-up to a corresponding directory on the external USB storage. That’ll do the trick. I have a DL4100 which has the same options and that’s what I do.