Movies Stop Playing

I just got my Live Hub a few weeks ago.  All of my vob files are in the internal storage.  The first movie I was watching stopped and went to a black screen about 90% into the movie.  I restarted the movie several times and fast forwarded to try to get to the end, but it always stopped in about the same place.  I was able to play the file to the end on my IPAD2 through the 8player app so it seems like the file itself is ok.  I tried testing some other files on the Hub and some fast forwarded through to the end and some didn’t.

Any ideas?


There are lots of threads about video issues on the forum.

The one common denominator is what was used to rip the DVDs. Some applications make very slight changes to files, and the Hub does not seem to be that tolerant to certain things.

Please supply more info on Application used, and you may be able to get more answers.

It was DVD Shrink 3.2.  I had problems with my old WD TV HD media player stopping after every separate VOB file so I combine everything into one big VOB file with a video_ts.ifo file.  I don’t rename the file so it is just VTS_01_1.VOB in every movie folder.


Mmmmm well another thing I have noticed is people playing ISOs have a much better outcome.

I can imagine its a pain, but instead ofnoutputting a VOB try an ISO file.

It is a pain I know, but unless you get lucky and a firmware update fixes it, it may be the only option you have. Maybe someone else will chime in and give you other options, but if they don’t work, there really is no magic setting to change that does not involve you having to redo a collection I’m afraid.

Does the same thing happen if you play it with vlc on your computer?   I’ve tried many many tools over the year, and there are just some movies that have to be dumped/decrypted to the hard disk before using another tool like handbrake/dvdshrink/bytecopy on them.

To be sure I’m redoing one now because bytecopy didn’t copy the whole movie to the mkv, so I’m dumping it with dvd decrytper first.

Thanks for the feedback.  I guess I’ll have to start working on redoing my files.

I’ve noticed that my WD TV Live Hub doesn’t like VOB files.  I have since switched to ISO rips and all is fine.  The other thing I’ve tried with success is changing the VOB container to a m2ts container using tsmuxer.  Works a treat.

I am going to have to google what that means, but I appreciate the input. Can I convert an existing vob or do I have to rip the movie again? Thanks again

Has there been any resolution to this? I’ve searched around but can’t find where WD has addressed it. All my long movies stop playing around the 2 hr mark (mkv, mpeg4, vob, xvid…it does not matter what was used to create them, nor the file type). Even running through PS3 media server has the same problem. No issues streaming on a PS3. This has to be a firmware bug worth fixing!

Same problem here - looks like any VOB over 4.3GB or so will stop before it’s done.  There is a switch in DVD Shrink to break VOBs into 1GB chunks (recommended by DVD shrink).   Seems to have fixed my problem.