Movies lag when streaming from wdmycloud

Hi all,

This is the problem im currently having.  

I currently have a WD My Cloud 2TB attached to a Buffalo Gigabit Router.  Attached to the router i have 2 Asus Oplay media players (first model HDPR1) attached to the physical network

Everything was working fine until around 3 weeks ago.  Suddenly the movies started lagging and stopping for a couple of miliseconds constantly.    Tried replacing cable from router to Mycloud and no go, same issue.

When i try selecting UPNP instead of the network, from the player the movies play normally (but i cant get subtitles so that is not an option)

Could you please advise what the problem could be?   

Thanks in advance,


Have you tried rebooting the My Cloud and/or router?

firmware update maybe?

if so

search on forum for downgrade solution

What method are you using to access your drive? I’ve found that in my network, large video files will lag when using samba. Via DLNA or NFS there’s no lag.

What speeds are you getting when copying files to or from your My Cloud? If slow, then your problem is your network.

You could also see what processes are running by using the “top” command via SSH and try to troubleshoot from there

Im using an Asus Oplay HDP-R1 (First model) It only lets me connect via network or using UPNP… When getting trough the network share it lags but if i dot it tru upnp it works fine. I have 2 media players oplay and the same thing happens. FYI. It didnt happen before, it used to work fine and suddely both devices started having issues Thanks

are you sure device is not indexing stuff

try disabeling upnp

see if it make a difference

also as mentioned above nfs share are always the fastest sharing method