Moved country, drive won't power up, can't get replacement!?

Hi, I’ve tried getting support from Western Digital or G Drive or whatever they are is but their support is utterly hopeless.

I purchased a G Drive 4Tb in the USA barely a year ago.
It’s my backup.

I come to Australia due to coronavirus, and made absolutely sure that I got the same power cable with the same voltage.

But it won’t turn on, at all, no matter what I try.

I’ve tried getting support from G Drive or WD or whatever company they are.
They keep telling m I have an RMA.
I have no record of an RMA.
I don’t even know what an RMA is.

Can SOMEONE help me please???

What AMPs is the replacement power supply ?

Also, have you tried original 12V AC adaptor you were using in the USA ?

it will work fine in Australia, just need a $2 plug adaptor to convert the contacts to our power plug socket.

I’ve tried it with the original power supply, and an adapter. The drive powers up, the light comes on, but I’ve tried connecting it to FOUR different computers, and NONE of them register the drive at all. I even looked in disk utility. It simply isn’t being registered by any computer.

Can you help me work out what this RMA thing is? They say I have some RMA thing but I don’t have any record of it.

Their support is seriously hopeless.