Mounting nfs share from linux (FSG-3)

Hello all,

I have a problem mounting the WD Sharespace via nfs on a linux machine (specifically, the FSG-3).

In the Sharespace configuration I have enabled nfs. I set it to accept all connections. I have set folder share permissions enabled with nfs and accesible as Public.

When i log in to the FSG, as root, I try to do the following mount command:

/ # mount -t nfs /mnt/nas

The error I get is:

mount: Mounting on /mnt/nas failed: No such device

Thinking it might be the FSG-3 machine, I tried mounting the Sharespace’s nfs share via a live-cd of Ubuntu. This time I get the following:

root@ubuntu:/# mount /mnt/nas
mount: wrong fs type, bad option, bad superblock on,
 missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount. helper program) In some cases useful info is found in syslog - try dmesg | tail or so

When i set the mount option to use cifs,  as follows:

root@ubuntu:/# mount -t cifs /mnt/nas
mount error(13): Permission denied

It asks me for a password. I have tried all user acount passwords. None work.

Mounting with the ‘-t cifs’ option from the FSG results in the same  ‘No such device’ error.

What am I doing wrong?

Please help me since I am using the FSG as a webserver, wanting to store the actual content files on the nas, since I am not at all with how twonky  displays its photo-albums (will this get fixed? I mean if you click to enlarge one picture it seems to load in large all the other pictures beneath it in the folder. This takes ages even over the network).

Thank you.


Well I’d begin by suggesting you use something besides NFS. This may be the ultimate root of your problems…

In addition on the CD you didn’t use -t nfs when mounting it.