Mountain Lion and the WD SmartWare install

I’ve tried numerous versions of the WD SmartWare installer, and it just hangs. I have to force quit out. Is this software compatible with Mountain Lion?

Looks like it was patched tonight. I guess I was right :slight_smile:

I just installed Mountain LIon and now it says my 2TB My Book is read-only. Is there any way to fix this? It worked just before the install. I am not a developer. Please help! Thanks!

1 Like

lillie-beth wrote:

I just installed Mountain LIon and now it says my 2TB My Book is read-only. Is there any way to fix this? It worked just before the install. I am not a developer. Please help! Thanks!

Seconded! Just installed Mountain Lion and all of a sudden I can’t write to my 2TB My Book. any word? I’m looking at a pretty big crisis if I can’t resolve this soon.

This is happing to me to I have my system pretty much to max, and I really need to dump some files onto my external drives both mybooks and I can’t access them.

Not happy, can someone fix this please!

I’ve got a 500gb WD my passport. I updated mac to mountain lion two days ago and now I can’t  even view the files on my disc, let alone access time machine. I really need a patch to be released ASAP

Exactly the same problem here. Cant access anything stored on it, including my iPhoto, iTunes or Aperture libraries. Pain in the **bleep**. Help WD!

Looking at the number of Mountain Lion threads on here, this is clearly a WD issue with the new OS (and it appears to only apply to WD drives by the way). 

I don’t see any response from the manufacturer either on their support pages or their forums despite the number of comments and calls they’ve no doubt recieved.

There is disregard for your customers, and then there is Western Digital…


  1. Is your Mt. Lion OS-X an upgrade from Lion OS-X to Mt. Lion or clean an install Mt. Lion (without any previous operating system)?

  2. What is the Build #?  Go to Apple > About this Mac > Click Version 10.8 to find Build #.  

12A269 = 10.8.0 Retail 12B19=10.8.1

  1. How is your drive partitioned?  APM or GPT?

  2. Is the the version of your FirmWare of the My Book or WD drive?

Go to Apple > About this Mac > More Info > System Report > Hardware USB or FireWire > My Book > Firmware Revision

  1. How long does it take to fail?

  2. Is 100% reproduced?

  3. Are there any software running?  WD SmartWare or any other 3rd party SW?

  4. Have you tried 10.8.1 update?

I’ve had terrible trouble with Smartware since upgrading to Mountain Lion (and 10.8.1 too); smartware crashes, and slowed the macbook to almost zero. Removed smartware from the Mac but  now can’t use the external passport drive without replicating the problem. about to throw passport away, though it was great while it worked. disaster

I have build 12b19 on OSX 10.8.1

I have a WD My Book Essential 2TB.  Since installing Mountain Lion as an upgrade from Snow Leopard (skipped Lion), everything has slowed down.  As a musician I keep all my samples and iTunes library on the My Book and everything ‘hangs’ more often than it used to.  Closing down also takes an age with the spinning wheel going for about 20 seconds.

My WD Smartware seems to be working OK. Should I update the firmware (very nervous of this as I can’t afford to lose any music files)? 

I have a macbook pro - have been using My Passport for Mac with it for 2 years.

Since upgrading to Mountain Lion - suddenly doesn’t recognize it !!!

I have :

  1. upgraded firmware

  2. submitted 2 requests to customer service for assistance

NO HELP - anyone have any better luck?

I know this is a problem for many people because it is all over the message boards.

Come On WD - fix this.

Are they discarding long time users because they’ve come out with a new product ???

If this isn’t resolved, they have lost one more consumer.

I’m having this problem. Since my upgrade to Mountain Lion the drive won’t mount to my Mac. 

Not sure what to do as I need the files I have on there…