Mountain Lion 10.8.2 and WDTV - Help setting up network share

New here guys, need some help, just bought a iMac few days ago, and I want to use it to stream movies to my wdtv media player. 

I use network share as its much quicker rather than a media server, I have the wdtv connected to my iMac via a Ethernet cable, I used to stream it the same way using my PC running windows 7 which worked fine. 

My iMac is running Mountain lion 10.8.2 and my firmware on the wdtv is up to date. 

So far I have done

System preferences > sharing > file sharing > turned smb on, ticked my name put in my password

On the wdtv box, my name came up when I went into windows share, put in my full name as it is on my imac and password and I am getting this message now

“Unable to connect to the selected source. Please make sure the selected source is active and available for sharing.”

Did I put my username or password in wrong? I don’t really know where to go from here. 

Thanks for any help in advance. 

There is an incompatibility between the newest mac version of SMB and that of WD.  WD posted a fix using NFS (Linux sharing) instead.  It takes a bit of network-foo, but it worked pretty well for me.  I could play files on WD from my mac running Mountain Lion.

Make sure you use your shortname where it wants you to put your mac user name.  And on the WD, don’t forget you have to turn Linux sharing on in setup.


Sweet thanks! Will give it a bash.

Appreciate it.

Hey there couldn’t find my old post.

Thaks for the offer to help.

I’m still having troubles and Have tried the steps  few times with no luck. I have even changed the share folder to the example name to see if that works. 

There might be a couple of things that could be the problem. The first is when I do the Terminal edit and enter the sudo dets I have problems with the local host line showing up. See attached

Screen Shot 2012-10-22 at 8.08.33 PM.png

it doesn’t seem to bring up the IP address verification.

Could this be the problem?

The other thing I think it could be is the IP address itself. In the exports text box you need to create it says enter the IP address of the WDTV Live. When I bring this up on the TV  it is different to my IP for the Imac I’m try to network with, do these need to be the same?. It looks simple and I’m sure it is but I feel I’m missing a step.

Any Help would be great?

Hi bio236,

I think the problem might be the IP address you are putting in your exports file.  That should be the IP address of the WD unit, if I recall correctly, and it must of course be different from your computer’s IP address.  You can find that information in the WD Setup screens somewhere.  For me it is a local network address, I can’t remember how they are set up but simple numbers like  

Make sure your exports file has no file extension and is in the correct directory.  You might post the contents of the file if you’re still having trouble.

Keep us posted.



FYI, here’s the content of my exports file:

/Users/jim/Documents/Movies/ -mapall=jim

The computer itself has the IP address

I have the same issue with using the exports file. The ip of the WDTV is but it does not show when issuing the showmount command. I’m pulling my hair out. This should be so easy. Has anyone figured it out?

trstam wrote:

Has anyone figured it out?

Yes, as I said, it works for me.  It’s hard to provide advice without a lot of details, including the pasted contents, filename/extension, and location of your exports file.  Make sure you’re using the short (unix) user name for your account, and that you’re sure you’ve turned on sharing for the folder you want to share.  Maybe the easiest thing is to carefully go through the instructions again and make sure you’ve followed them to the letter, if you haven’t already.  The instructions are clear and detailed, but they’re formatted in such a way that they are hard to follow. is a pretty high number.  Wifi routers may reassign addresses to devices as they come on and off the network.  I would check over time and make sure the WD address stays the same.  If not, you may need to assign it a permanent address in your router setup.  However, that shouldn’t affect the showmount command on the mac side I don’t think.


Thanks. I’m following the instructions to the letter except with textedit as follows. My path is a fairly long one which I’ve checked several times. My username is Ted and that’s what I’m using for my unix short name. I’ve verified several times that the ip of the WDTV is not changing. I wondered about that number myself, but it’s correct and I can access it from my web browser with that ip. The mapped folder is checked shared.

I think it might be the textedit exports file. ML textedit does not give the option to save a version as described in the instructions. It only gives the option to save. So, I am chosing the plain text format and just saving it on my desktop. Then I drop the extension and move it into /etc with authentication.

Any insight here?

You went into the Format menu of TextEdit and chose “Make Plain Text”?  You made sure there was no extension if you have show extensions disabled, which is the default in the Finder?

Exactly what is terminal telling you when you try showmount?  I just went through the process again, and got the following:

Jims-MacBook-Pro:~ jim$ sudo nfsd restart
Jims-MacBook-Pro:~ jim$ showmount -e
Exports list on localhost:
Jims-MacBook-Pro:~ jim$

 So it worked.  Then I renamed the exports file so it wouldn’t work and tried it again to see how it would behave:

Jims-MacBook-Pro:~ jim$ sudo nfsd restart
Jims-MacBook-Pro:~ jim$ showmount -e
showmount: Cannot retrieve info from host: localhost: RPC: Port mapper failure - RPC: Remote system error
Jims-MacBook-Pro:~ jim$

Here’s the funny part.  When I named it back to exports again, I got the same error in Terminal.  I’m thinking I would log out and back in, but I can’t do that now.  You might try it.  Anyway, I may have reproduced your problem, but I don’t know how!


logging out and back in did the trick.  When I then did the nfsd restart command (probably not needed after login ), then showmount -e, I got the positive response.  So while mucking around with this, things might get fouled up that a logout/login is needed to fix.

Thank you. I get a blank line after Exports list on localhost: and then my computer name and username. It’s the blank that’s throwing me off. I get neither the correct mapping you get or the error you get when you renamed exports. I have not tried logging off or rebooting. 

This is the same thing that was happening to the other fellow earlier in the post.

Here are the 1) exports file contents and 2) terminal out put. Note that there is nothing listed after Exports list. This must be the problem. I just don’t know why it is happening.

/Users/Ted/Music/iTunes/iTunes Music -mapall=Ted

Teds-Mac-Pro:~ Ted$ sudo nfsd restart
Teds-Mac-Pro:~ Ted$ showmount -e
Exports list on localhost:
Teds-Mac-Pro:~ Ted$

I wonder if there is something funny about an iTunes folder.  Have you tried sharing an unrelated folder?  Also, it’s funny, in my iTunes folder, I don’t have a folder called “iTunes Music”  I have “iTunes Media”.  Have you got the right folder?

Also, since the folder name has a space in it, you might have to escape the space with a \

Do you have File Sharing turned on in the Sharing preference pane?

Is the folder designated for sharing?

Is it the exact folder listed in your exports file?

Thanks. Yes on everything. It’s iTunes Music because I’m a previous windows user and I moved it over. iTunes works perfectly. The path and exports text is listed in my prior email as is the showmounts -e output.

Very frustrating

Yes on everything means you did try escaping the space, and you also tried to share other unrelated folders?  

No, sorry. Those will be tried tonight.

The space in the path is likely your problem.  If you read the exports man page, it says spaces in the path must be escaped or the path quoted.

Thank you again. I will try it. I do not have the manual so I will fill the space with a backslash.

You don’t need a “manual” for such information.  I’m referring to the unix man pages.  In terminal, type “man exports” and you should get an outpouring of info on how exports files should look.  Hit space for the next screenful, control-c to end it.

Don’t replace the space with a backslash, put the slash before the space.  The slash tells the system that the space is part of the path, not the end of the path and on to the next part of the line.  Or just enclose the path in single or double quotes

One step closer. The quotes worked. Now when I try to connect the nework share from the WDTV Live Hub I get an invalid username and password error. I know my username and password and I’ve reentered it several times. Any ideas? I have all forms of network shares enabled on the WD. Should I just enable linux?

Here’s the terminal readout which looks good:

Teds-Mac-Pro:~ Ted$ sudo nfsd restart
Teds-Mac-Pro:~ Ted$ showmount -e
Exports list on localhost:
/Users/Ted/Music/iTunes/iTunes Music
Teds-Mac-Pro:~ Ted$

Nothing should be this painful. I logged off and on and now I get past the username and password, but I get this which is where this post started for someone else. I have linux and windows shares enabled, but have tried each independently. Same issue. And yes, sharing is enabled for the mapped folder. Both share files using AFP abd share files using SMB are enabled. 

“Unable to connect to the selected source. Please make sure the selected source is active and available for sharing.”

So close, yet so far. Thanks for hanging in with me on this one.