Most issues at one time?

I don’t mean to create a negative post for the sake of it, or ‘troll’ WD or their products. I’m honestly curious about this after my experience today.

I’ve been talking to support for about 4 months, and finally they agreed to send me a brand new WD Live to replace the defective box. Well…this one is miles worse than the prior one. Today is a perfect example;

  1. Turn box on and immediately get a pink screen, which is remedied by resetting the hdmi cable.
  2. Try to finish playing a movie and get a “file format not supported”…even though I was watching the same file earlier in the day (mkv). I pull the power cord for a few minutes, than restart the box.
  3. Finally got the file to work, but noticed that pressing the ‘ok’ button brings up the ‘jump to’ command. Hitting ‘ok’ removes the command box, but now the timeline wont disappear. I hit back, than tried playing the file again only to now have the eternally spinning loading symbol. I went to the boxes setup menu and hit “restart box”.
  4. Got the box back up, but still can’t play file. Pulled plug for five minutes, than tried again, only to get the pink screen again.
  5. Here we go, back to step 2. Again getting the “file format not supported” message.

Seriously??? I will admit that the box is on the original firmware (1.00.42). Was hoping it would help some of my issues. I may try updating, but also seems that the current one has it’s own issues (as I experienced before).

This is literally the worst experience I’ve had with a product…released by a reputable brand. I would expect this from some no-name Chinese import, NOT a firm as large as WD. My Asus O!Play never had these kind of issues (wasn’t perfect, but was also pretty solid).

Getting really close to moving away from WD products all together, maybe going with one of the android boxed, but really wanted something simple.

Hello there,

I am sorry to hear you have gone through such a bad experience, try to update the unit, if you want you can do an update to the next firmware after the one your unit has not necessarily the latest. Please check on this link, hope it helps:

Thanks for the response. I updated it to 1.02.17 (not sure about the exact number). It was able to play the file. Just seriously disappointed in the whole experience.