More Time Machine Issues

Well, I guess I’m the first to write about this.  Again, as with every OSX upgrade, I made the unfortunate decision to install Mavericks on my MacBook Pro when it came out, expecting the MBLD to work as it always has.  I even tried to be careful this time around by reading the release notes, which said the latest firmware update had addressed Time Machine compatibility in Mavericks.  Evidently not.  I’ve gone two weeks without a backup now.  As with Mountain Lion, I open Time Machine in my Preferences, click the MBLD, and sign in as “Guest” like the manual says.  Around 5pm I would make my computer back up and it would take an hour or two to “prepare backup,” then only actually back up about 1 or 2 gigabytes per 8-12ish hours, so it would never finish because I have to go take my computer to work in the mornings.  Now tonight it won’t even prepare to backup, all I get is an error message that says “The disk image XYZ.sparesbundle is in use.  Try ejecting the disk image.”  It doesn’t matter whether the drive is actually mounted to my desktop or not, it gives that same message.  I’ve just about had it with these WD NAS units.  The only reason I have this MBLD is because WD sent it to me when they ran out of replacement Sharespaces (which I originally had) since each one consistently failed to hold my backups.  While the MBLD worked ok under Mountain Lion, it would still consistently prompt me every month that it couldn’t verify my backups and had to make a whole new backup.  

Having finished my frustrated rant, I know I probably have two separate Time Machine issues, but if anyone has any useful information to A) get my Time Machine working at least once and B) keep it consistent enough without having to verify and start a completely new backup every month, I would greatly appreciate any advice you might have.

Hi mtan123, I recommend you to contact tech support on this case, they should be able to help you with your problem.

I’ve tried that, I’ve sent WD emails through the MBLD itself and from the WD website.  No one has gotten back to to me within the alotted 48 hours of the email being sent.