More Time Machine errors

Several times now, Time machine has given me the error “Time Machine completed a verification of your backups. To improve reliability, Time Machine must create a new backup for you” when backing up to my 3TB MyCloud.

It happened yesterday, the second time in about a week; I just completed the backup midday today. But again this evening (the same day the new backup completed), Time Machine gave me the same error.

Before doing yesterday’s new backup, I ran the Full Test in Settings>Utilities and it passed.

The MyCloud is connected via Ethernet, not wifi.

What’s going on?

Firmware Version WDMyCloud v03.04.01-219 

1 Like

I have the same problem.  Has occured twice in the three weeks that i have been using MyCloud.

Yep, I get this regulalry and at random.  Sometimes time machine ™ backups run well for a few weeks then bang, you have to do a complete backup again.  I usually do this over a wired connection to the router as it is much faster.  Also once the TM share got corrupted, I had to delete it then create a new TM share before TM would use it.  Using OS X 10.9.2.

You might want to try this next time it fails. Works for me.,08,27,169,fix-time-machine-sparsebundle-nas-based-backup-errors.html

1 Like

Yes, I saw that… of course, I only came across it after I’d OK’d the new backup. :frowning:

Cheers, I’ll give that a go next time it occurs.

These long sets of (fairly scary!) commands to be typed in Terminal are all well and good – but this doesn’t really solve the underlying problem:  a backup should be secure, reliable, and effort less.

after struggling and giving up with NAS based Time Machine backups several years ago, I reverted to using Time Machne to a connected USB drive.  The amount of effort required to keep my Mac backed up was about 2-3 minutes a year, and it was reliable (until I ran out of space…)

WD is now telling people that Time Machine to NAS (MyCloud, amongst other devices) is viable.  But my expeience (3 unreliable sparse bundles that needed re-creating in 3 weeks, combined with the hundreds of postings from others in this forum who ae having the same problem – say that this is just not a safe and reliable way of doing backups.  Sorry, but having a backup that fails for a day or two every few weeks leaves your material very, very vulnerable!

WD - if you can’t do this (for whatever reason atributable to WD or Apple), why do you continue to say that this works when all the evidence screams that it doesn’t work in a safe and reliable way?

I’d had FireWire TM drive, but after a five or so years it started to fail–and subtly enough that only repair utility software noted potential issues. As I also have a second computer (a MacBook) that I wanted to back up, I went for the NAS to conveniently back up both.

Never once did I have this sort of problem with the FW drive.

i have the same problem:neutral_face:

seems it a apple’s problem. It happens to Time Capsule, Synology, QNAP…too 

see here

My point is that if this does not work on a WD NAS system, whether  from WD or others, whether for WD’s bad or Apple’s bad, WD SHOULD NOT BE SELLING DRIVES CLAIMING THAT IT DOES WORK.

All the evidence from this forum suggests that this feature has not been working in any reliable way for seeral years now.  But WD conytinues to bring new products to market claiming t hat it does work.   

In my cae, I knew that there had been issues several years ago, so checked with WD Support before buying and was told that it worked, in addition the packaging and documentation says that it works.

It Just Doesn’t…

Well, tried the fsck a few times, and received the following each time:

journal_replay(/dev/disk3s2) returned 0

** /dev/rdisk3s2

Using cacheBlockSize=32K cacheTotalBlock=81920 cacheSize=2621440K.

   Executing fsck_hfs (version hfs-226.1.1).

** Checking Journaled HFS Plus volume.

   Invalid extent entry

(4, 0)

CheckExtRecord: id=4 1:(510983,0), (blockCount == 0)

** The volume   could not be verified completely.

volume check failed with error 7 

volume type is pure HFS+ 

primary MDB is at block 0 0x00 

alternate MDB is at block 0 0x00 

primary VHB is at block 2 0x02 

alternate VHB is at block 5641594414 0x15043e62e 

sector size = 512 0x200 

VolumeObject flags = 0x07 

total sectors for volume = 5641594416 0x15043e630 

total sectors for embedded volume = 0 0x00 

CheckHFS returned -1317, fsmodified = 0

Forwarded the info to Alsoft (makers of DiskWarrior), including DW errors reported. They replied, spefically referencing the error DiskWarrior reported: “An error (-36) is an input/output error.  In this situation it indicates a problem writing to a device.  Likely there are bad blocks on a drive in the NAS - which means a drive is beginning to physically fail.”

I would also note that I sent a support question with this info to WD; they replied after a couple of days with a totally useless, awful answer, as if they hadn’t even bothered to read the question. They even sent me a link to how to format a drive; but the info only works for non-network drives (i.e., directly hooked up) and is not at all relevant to the MyCloud.

Erased the My Cloud using the Dashboard (Settings>Utilities>System Factory Restore>Full Restore) then started from scratch with a new backup.

This evening. Time Machine gave me the same **bleep** error.

Never had a single problem with YEARS of backups to a FireWire drive; backing up to a My Cloud, I get it weekly or more.

I get the same deal when backing up to an actual apple Time Machine… 

Apple has neglected this software in my opinion and frankly it is rubbish. Look for alternative back up systems.