Mojo

hi there

i have succesfully loaded the mojo osd mod onto my msp and have followed the instructions to the letter re using thumbgen and setting it all up as needed, i have tried all mojo templates and can get a background picture, rating stars and a couple of small information boxes but no movie info…plot,actors runtime etc…any ideas

The metadata isn’t generated on the moviesheet, but by the HUB from the “movie.xml”.

im not using the hub i am using the smp…what does that mean for me:smiley:

so does the template kind of superimpose itself over the metadata generated by the player itself  ???

please have pity on a dumb newbie  (:

I don’t know what that means for you, as I don’t have the SMP.  But the firmware for the SMP is fairly similar that of the HUB.  So if I say the “HUB” the SMP is included in that.

No the template does not superimpose over anything and it has nothing to do with what is collected by the player.  The template is only for Thumbgen so that it can generate the moviesheet.  The xml that you should have generated with Thumbgen contains the “overview, actors, runtime, etc.” (the text and the moviesheet are seperate) and this is displayed as a layer on top of the moviesheet (backdrop) by the SMP.   You should actually see this before the moviesheet begins to display.

When you generate the moviesheet this is how it should look:

FAST FIVE_sheet.jpg

View HERE.

thanks for the reply, yes i have got to the movie sheet as you have shown but when i look into my movie folder i do not have an xml file, however when i use the default thumbgen template everything is where it is supposed to be,overview runtime etc and the only thing i change is the template type

i have checked and rechecked the input/output naming tab

Like I said, the overview, actors, etc. are NOT supposed to be on the moviesheet.  Those things are added by the SMP from the xml data when you view the file on the SMP.  The moviesheet should look exactly like the one that I posted above, you will not see the overview, actors, etc. until you view it on the SMP.

If you don’t see the metadata when you view it on your SMP, then you are either missing the xml file or the SMP is not pulling that data from the xml file for some reason.

ok i generated the movie sheet as a test for one of my movies but nothing is showing, not even the template is showing up…according to your guide  re setting up thumbgen for the hub there should be an xml file generated along with a filename_cover, filename.png and a filename_sheet.jpg ( the last 3 i have) i think this is the problem, is there anything else i could try as i would really love to get the trickle set up

cheers

If you are going by the written guide, then you need to look at pages 5 and 6 and make sure that you have the correct boxes checked for “Generate” and you have the  “Movieinfo export” setting correct.

If you are not generating an xml, then it is most likely because you didn’t put a check mark in the box next to “Movie information” under “Generate”.

If you do have the box checked for “Movie information”, then the other reason is because you are generating the wrong type of file, most likely an .nfo, which means you don’t have the correct setting for “Movieinfo export” under the “Input/Output Naming” tab.

hi and thank you for the time you are spending helping me out, all the correct boxes are checked for generate and the movie info export setting is correct, there is also a check mark in the box movie information under generate and all my settings under input/output naming tab are correct

still not getting an xml file

Well, exactly what files are being generated?

Options menu_MI.jpg

If you have a check mark in the box that’s highlighted in the pic, then you should be generating something, it’s just a matter of what.

i am getting everything BUT an xml file

I know your saying everything is being generated except the xml, but it would help me help you if you tell me exactly what files are being generated.

filename_cover.jpg

filename.png

filename_sheet.jpg

So, let me ask you this, do you have .Net framwork 3.5 SP1 installed?  It has to be 3.5 SP1.

i have .netfx40, am installing 3.5 now

still no xml

Ok, make sure that it’s 3.5 SP1. 

If it’s still not working though, try deleting Thumbgen (delete the entire TG folder) then reinstall it.

deleted tg, reinstalled, made all changes , still no xml 

Well, I’m stumped then. You should probably try to find an answer over at the Thumbgen forum here:

http://forum.wdlxtv.com/viewforum.php?f=25