MOJO 1.08.06 (Official Release) UPDATE 4/24/11

This is the Official Release of MOJO.  If you like this theme, please click the Kudo’s star to the left (or I will accept cash :wink:).

UPDATE (4/24/11):  This update is to fix issues for multiple selecting files.  Also added new keyboard buttons (english only) and adds  more changes for text coloring in Setup menu.

READ ME BEFORE USING:

FIrst, a WARNING.  If you are using the latest firmware (Version 2.05.08), you will find that there are problems in how overly long text are displayed.  This is not a theme issue but an issue with how the firmware handles text.

If you have previously used either the beta version of MOJO or the Anodized theme with the Trickle effect, then there is nothing new that you need to know.

If you are new to this, then here’s the instructions on how to get the effects shown on the pics below.

First, download the theme, then unzip it to your PC and copy it to the “.wd_tv/theme” folder on your HUB.  Make sure that you unzip it to your PC first, as there have been instances where copying it directly to the HUB has corrupted the theme.

Next, you will need to download my Thumbgen (TG) Cover Box templates from HERE.  If you are not fimiliar with TG then there are several places to find HOW-TO’s, including in this forum and HERE.  Although it is not necessary to use the Cover Box templates (the thumbnails you have using Get Info on the HUB should mostly work also), you will be missing out on the styling if you don’t use them.  If you decide that you wish to make your own Cover Boxes, then you should make sure that they are made to be 251 X 482 in size, this is the best size for them to display, although it is not necessary to have them this size, it is necessary to keep the same ratio.

Another thing you will want to do is to have a bunch of videos in one folder.  This is not required, but you will again be missing out on the styling as shown in the pics, due to the fact the the HUB (at least with the latest 3 firmwares) does not allow transparent reflections to be displayed for folder thumbnails nor metadata or background images.

An example of tthe file structure (and how I have mine) would like this:

          ACTION (folder)

                  movie1.mkv

                  move2.mkv

                  movie3.mkv

                  etc.

         ANIMATION (folder)

                 movie1.mkv

                 move2.mkv

                 movie3.mkv

                 etc.

So without any further delay, here’s the download link:

MOJO 1.08.06 (Updated 4/24/11)

If your using Firmware version 2.06.10, see HERE for Game Addition.

Gunmetal render.jpg

Gunmetal_dashboard_render.jpg

Gunmetal_Gallery.jpg

Large_video.jpg

Mojo_preview_new2.jpg

Video.jpg

video_list_render_movies.jpg

Pics can be viewed from HERE.

35 Likes

MUSIC VIEWS:

Mojo_album.jpg

Album_playing_render.jpg

Album_playing_overview_render.jpg

Gunmetal_now_playing_render.jpg

Once again love this theme . Don’t know what’s going on though can’t seem to get the preview view to work. Both times ive tried to set the theme up my internet connection shuts down. Any ideas greatly appreciated thanks

I installed this last night.  Looks GREAT! 

FYI - I’m not using the thumbnail template, just the ‘Get Info’ on the hub and it still looks just fine. 

Great looking and well working Theme for me.

But one thing that do not work for me:

I´m using ThumbGen to create a xml file of a movie. ThumbGen finds all the movie data with the explanation text of the movie, an puts this description in the created xml file.

The bad thing is, if the description of the movie is very long… e.g. five sentences…the whole description will not be shown in the theme. There  is also no possibility to scroll up or down e.g. 1/2 and 2/2.

So all is working fine but cannot view the whole gathered movie information.

Bug of the theme or the firmware?

Am i missing something?

THX for help…

Gandalf - This is going to be common of almost every theme, even the legacy.

I know that if you use the ‘Get info’ to generate the xml, you can view options then select View Info to see the entire text.  I don’t know if that will work with the ThunbGen XML but it may.  Give that a shot.

gladster wrote:
Once again love this theme . Don’t know what’s going on though can’t seem to get the preview view to work. Both times ive tried to set the theme up my internet connection shuts down. Any ideas greatly appreciated thanks

gladster,

As I can’t duplicate it on my end, I can’t say why you can’t get the preview view to work.  Also, I’m not sure what you mean when you say "Both times ive tried to set the theme up my internet connection shuts down.’.  If you could tell me exactly what you are doing I may be able to help more.

If you are having problems, you can try this first.  Re-download the theme, unzip it to your PC, then copy it to the HUB from your PC.  Some times you can get a corrupted download, or something doesn’t copy right.  Let me know if you still have problems.

Great work TW!

Thank you. will try out later when the wife goes to bed and i can get on the tv set!! LOL.

The visuals look great and I imagine the theme will work pretty much BUG free! Wd should offer you a job man!!!

Anyhow, thanks again and I guess you can put your feet up for a while on the theming front and watch some movies on the HUB as we all INITIALLY intended! :slight_smile:

gandalf12 wrote:

Great looking and well working Theme for me.

But one thing that do not work for me:

I´m using ThumbGen to create a xml file of a movie. ThumbGen finds all the movie data with the explanation text of the movie, an puts this description in the created xml file.

The bad thing is, if the description of the movie is very long… e.g. five sentences…the whole description will not be shown in the theme. There  is also no possibility to scroll up or down e.g. 1/2 and 2/2.

So all is working fine but cannot view the whole gathered movie information.

Bug of the theme or the firmware?

Am i missing something?

THX for help…

gandalf12,

As Steve_V said, this is true for any theme.  The Gallery view will only display a certain number of lines that have been set in the xml.   This only way to display the entire Overview is to go to “Options” then select “View Info”.   The Gallery View does not scroll or have an options to go to the next page.

Hey, architectonic,

Thanks.  I can’t put my feet up yet, there are still somethings that need to be done to MOJO.  I’ll have to release an update in a week or 2, because I didn’t have time to do everything I needed to.  I have to add things for the “mulitiple edit” and do some things for the text in the Setup menu (just some color changes).  Other than that everything else should work 5 X 5.

Also, I have some ideas for a new theme that I may start working on fairly soon.  I’ll have to see how it looks once I get some renders made.

Anyway, thanks again.

TW

OK, It’s an awesome theme. No doubt about it. But…

I just hate to give up coversheets. You did an outstanding job of replacing them but…

Well I hope when you’ve taken some time to rest, Maybe you could wedge a sheet into another version of mojo for us diehards. List or gallery.

Hi Tinwarble- tried x3 times finally successful and every thing seems to work ok now - don’t know what I did wrong ( sometimes I hate technology!) anyway looks great my favourite by far. Thanks heaps for all your hard work

Hey gladster,

Yeah, technology is great, until it isn’t.:smileyvery-happy:

zamzickles,

I like moviesheets also, and use them on my regular WDTV Live, but right now I’m not doing anything with moviesheets for the HUB.  I’m hoping that WD will get the hint and allow moviesheets to be displayed natively some time soon.

If not though, I may look into doing something so that they can be used with my theme some time later.

TW

Tinwarble,

Excellent work!.. I am truly impressed, You have got my vote!

With best wishes

Vistawall

Hi,

I would like to thank you for your theme !!

Great work !

I have created a TV show template based on your mkv white cover box.

You can find it here :  MKV TV White Cover Box

I have just added 2 text box with the episode’s title and the episode’s number.

If you don’t agree with this tell me I’ll remove it.

Thank you!  The music theme is light years beyond Mochi!!!

I noticed that the artwork appeared very low-res while browsing albums in List View.  But, when I selected an album the hi-res art that I used in the metadata tags appears.  Is there a way to get the hi-res art to appear before drilling down to see the album tracks?  I have a hi-res pic of the album cover stored in each album folder and the pic is called “folder.jpg”. 

Thanks again!!!

Thanks guys!

fanturi,

No, I don’t mind that you posted TV series boxes. 

chauncey,

No, you can’t make the folder cover art look any higher-res than they do.  This is a firmware issue, it seems to handle folders differently than it does file coverart.  It is the same for movies too.  I have posted an Idea to fix this issue in the Idea thread HERE, make sure you vote for it by clicking the UP ARROW to the left so that we can get this fixed.

Bump for Update.

Embrace,

It appears you have tried to post 3 times, but all your posts are blank. 

There seems be a problem with those using IE 9 or FF 4, so if you are using one of these that maybe why none of your posts are showing up.  Although, I use FF 4 and haven’t had any problems.

You may want to try a different browser if you are using IE 9 though or use IE 8.

FF4 works fine. IE9 does not work at all.

If using IE9 the posts are completely blank. Embrace, please use a different browser to post on these forums.

FireFox [any version], IE7, IE8, Safari, Chrome… NOT Internet Explorer 9