Mochi Tabs

I made a couple tweaks to the mochi theme and replaced the tab icons with my own however I cannot seem to get rid of the original font on the tabs My icons have the fonts on them but the original ones overshadow the ones I created example the movies tab still shows the original MOVIES font on the tab over the top of my icon. Any suggestions on how to remove this?

inc_rv_home_menu_node.xml

delete the text names (but leave a space)

eg.

<button valkey=“RV_HOME_MENU_VIDEOS”
            name=“Video”    
        normal_bg=“image/main_videos_icon_n.png”
        focused_bg=“image/main_videos_icon_f.png”
        disabled_bg=“image/main_videos_icon_n.png”
        animation_format_str=“image/video_icon_%03d.png”
        animation_num=“36”/>

to this …

<button valkey=“RV_HOME_MENU_VIDEOS”
            name=" "    
        normal_bg=“image/main_videos_icon_n.png”
        focused_bg=“image/main_videos_icon_f.png”
        disabled_bg=“image/main_videos_icon_n.png”
        animation_format_str=“image/video_icon_%03d.png”
        animation_num=“36”/>

further “example” from my “Alaska Theme” … if you unzip it, and take a look at the inc_rv_home_menu_node.xml

<?xml version=“1.0”?> <wrapper> <button valkey=“RV_HOME_MENU_FILES” name=" " normal_bg=“image/main_files_icon_n.png” focused_bg=“image/main_files_icon_f.png” disabled_bg=“image/main_files_icon_n.png”/> <button valkey=“RV_HOME_MENU_IPCAM” name=" " normal_bg=“image/main_ipcam_icon_n.png” focused_bg=“image/main_ipcam_icon_f.png” disabled_bg=“image/main_ipcam_icon_n.png”/> <button valkey=“RV_HOME_MENU_NEW_FW” name=" " normal_bg=“image/main_new_firmware_icon_n.png” focused_bg=“image/main_new_firmware_icon_f.png” disabled_bg=“image/main_new_firmware_icon_n.png”/> <button valkey=“RV_HOME_MENU_MUSIC” name=" " normal_bg=“image/main_music_icon_n.png” focused_bg=“image/main_music_icon_f.png” disabled_bg=“image/main_music_icon_n.png”/> <button valkey=“RV_HOME_MENU_PHOTOS” name=" " normal_bg=“image/main_photos_icon_n.png” focused_bg=“image/main_photos_icon_f.png” disabled_bg=“image/main_photos_icon_n.png”/> <button valkey=“RV_HOME_MENU_SERVICES” name=" " normal_bg=“image/main_services_icon_n.png” focused_bg=“image/main_services_icon_f.png” disabled_bg=“image/main_services_icon_n.png”/> <button valkey=“RV_HOME_MENU_LIVE_TV” name=" " normal_bg=“image/main_tv_icon_n.png” focused_bg=“image/main_tv_icon_f.png” disabled_bg=“image/main_tv_icon_n.png”/> <button valkey=“RV_HOME_MENU_SETUP” name=" " normal_bg=“image/main_setup_icon_n.png” focused_bg=“image/main_setup_icon_f.png” disabled_bg=“image/main_setup_icon_n.png”/> <button valkey=“RV_HOME_MENU_USERS” name=" " normal_bg=“image/main_users_icon_n.png” focused_bg=“image/main_users_icon_f.png” disabled_bg=“image/main_users_icon_n.png” animation_format_str=“image/user_icon_%03d.png” animation_num=“1”/> <button valkey=“RV_HOME_MENU_VIDEOS” name=" " normal_bg=“image/main_videos_icon_n.png” focused_bg=“image/main_videos_icon_f.png” disabled_bg=“image/main_videos_icon_n.png”/> <button valkey=“RV_HOME_MENU_FLASH” name=" " normal_bg=“image/main_flash_icon_n.png” focused_bg=“image/main_flash_icon_f.png” disabled_bg=“image/main_flash_icon_n.png”/> <button valkey=“RV_HOME_MENU_NOW_PLAYING” name=" " normal_bg=“image/main_music_nowplaying_n.png” focused_bg=“image/main_music_nowplaying_f.png” disabled_bg=“image/main_music_nowplaying_n.png”/> <button valkey=“RV_HOME_MENU_GAMES” name=" " normal_bg=“image/main_games_icon_n.png” focused_bg=“image/main_Game_icon_f_001.png” disabled_bg=“image/main_games_icon_n.png”/> <button valkey=“RV_HOME_MENU_RSS” name=" " normal_bg=“image/main_rss_feeds_icon_n.png” focused_bg=“image/main_rss_feeds_icon_f.png” disabled_bg=“image/main_rss_feeds_icon_n.png”/> </wrapper>

1 Like

well it changed it but now I see project-id-ver… on every tab I am assuming the dots are because the word is too long ofr the box and I see it on all the tabs that I have. Thanks for your help so far

tm224 wrote:

well it changed it but now I see project-id-ver… on every tab

that’s strange :confounded:  it should not be doing that

any chance you could upload your theme here (or send me a Private Message with a download link … so i can have a look at the xml code and sort it out quickly for you)

Ok I got it and as I reread your instructions I didn’t leave the space. One more thing I would like to do as this is for my grandaughter and I am doing a disney theme nothing major pretty much changing the images of the mochi theme how do I change the author it shows the name of the theme but can’t seem to find where to change that

meta.xml

<?xml version='1.0' encoding='UTF-8'?> PM4 WD http://service.wdc.com/api/screenshot\_1.jpg http://service.wdc.com/api/screenshot\_2.jpg <author>JoeySymth</author> 2010/08/01 05 0 A PM3 HD port to WDTV [http://service.wdc.com/api/default.theme](http://service.wdc.com/api/default.theme) grid TBD
2 Likes

Thanks a bunch

Would anyone a version of the theme LegacyWithWelo fully functioning with GRID, for example, the number of files in a hard drive? thank you