MLB Firmware issues!

Hi,

I need help! few days ago i got the notification to upgrade my firmware on MY Live Book 2TB so i clicked on upgrade and it messed up all my dvice… now the MLB shows no data … it says 0GB / 0TB (cant even upgrade to the newer firmware as it keep saying not enough memory/space)

Tried restoring it and it did and it lost everything then i careated new users given the same name as before i can see there is 63 GB use but no data and i can’t access the public folder at all it had off my life time pics on it!!

Any help would me appreciated!!! 

Ali

Habe you tried enabling FTP and getting at your data that way?
When you say you tried restoring it, what exactly did you do?

First i have pushed the back reset butten and it did nothing then i did the quick restore from the MLB dashboard

  •  If i enable FTP how would i get the data i am not very good at these thing :slight_smile:

at the moment i am on 021109-053 fireware… wiredly i can creat new users and able to store new data and  access via wd2go but cant see any of the old data if that make any sense?

Thanks for getting back to me nfodiz

I have very bad news for you. The quick factory restore deletes all data on the data partition of the drive. There IS a way to recover it but it requires you taking the drive out of it’s enclosure which would break your warranty and is probably outside your technical abilities?

Let me know if you want to proceed

to be honst I am not worried about the warranty at this point if i could get all of my pics thats all i would be happy with it even has my wedding pics on it (silly me for not having it backed up)

Please see the pic in properties it clearly says that it has 60 Gb worth of data in a drive and no data when i open the drive… :frowning:

I would love to procceed if you could help me and guide me through :slight_smile:

I can’t see your picture until a mod approves it. On the off chance your data is still there, let’s try this…

1) In a web-browser go to http://mybooklive/UI/ssh and you should see the following. Tick SSH Access Enable

 

  1. Download WinSCP from http://winscp.net/download/winscp510setup.exe

3 Open WinSCP and click on the NEW box

  1. Fill in the boxes as shown in the picture below and click the LOGIN box (The password is masked but it is welc0me)

 


 

5) On this next screen, click the icon I arrowed to in the picture

 


  1. At this next screen double click DataVolume

  1. At this next screen double click shares

  1. At this point you should see a list of your shares. Enter them and see if any of your data is actually there.

  2. If none of your old data is there, proceed to

http://community.wdc.com/t5/My-Book-Live/GUIDE-How-to-unbrick-a-totally-dead-MBL/td-p/435724

And follow Step 1 and Step 2

At step 2, you will probably need to use R-Linux for Windows, as the data has been deleted and this program should recover it.

http://www.r-tt.com/downloads/rli_en_4.exe

nfodiz: I am in the office at the moment and the MBL is at home… i wasnt expecting anyone come back to me that quickly which i really appreciate but can we do this in the evening if you don’t mind and if you could spare some time in the eveing? :slight_smile:

BTW i have enable the ssh access lastnight but did know what to look for and how to use it with PuTTY!

Thanks you so much for help and your time… i will wait till all the pics are uploaded and follow your steps :) 

Ok I will finish the guide. Follow it and let me know if you see any of your old data. If you don’t, I already have another guide on how to remove the drive and recover the data at:

http://community.wdc.com/t5/My-Book-Live/GUIDE-How-to-unbrick-a-totally-dead-MBL/td-p/435724

Just a quick note: the data I am after was in the Public folder which i can see as a folder in my MBL but it wont let me get in to it!

Follow the steps above and the public folder will be at /DataVolume/shares/Public
If the data is still there, you can drag and drop it to a folder of your choice on the left side window.

As for the Public folder not letting you access it, I have a guide to possibly fix that issue as well that you can try before you move to taking the drive out of the enclosure. It does what the quick factory restore does minus deleting your data. It should reset permissions for the folders. The guide is easy to follow with pics included :slight_smile:
http://community.wdc.com/t5/My-Book-Live/GUIDE-Factory-Restore-using-PuTTY-or-Terminal/td-p/513954

Don’t add any new data to your drive as doing so could prevent you from recovering some of your data if it places it on the same part of the disk as the old files used to reside.

As far as your picture goes with the used space and free space on the WEBDAV share through wd2go, that is not an accurate way to check drive space free/used… The Dashboard is the only way to get an accurate idea of disk usage. If you click the shares tab in the dashboard, it will show you how much data is in each share.

Hi nfodiz,

I have followed the steps you told me and when i go in to the Data Volume there is is only cache folder there see the screen print :frowning:

see the pic on here

Ouch, that doesn’t look good. I need to get a look at your partitions. Download PuTTY at
http://the.earth.li/~sgtatham/putty/latest/x86/putty.exe

Follow step 1 only at this link in the second post which shows you the commands to type to list the drive partitions
http://community.wdc.com/t5/My-Book-Live/Data-Volumes-failed-to-Mount/td-p/519784

This link will give you an idea of how to login to your drive using PuTTY
http://community.wdc.com/t5/My-Book-Live/GUIDE-Factory-Restore-using-PuTTY-or-Terminal/m-p/513954

login is root
password is welc0me

Copy and paste the output from the putty window

Hi, 

I have already taken the hard drive out of the box and attached with my home PC and when I look at the drive via DiskInternals Linux Reader it looks like this…  Which i dont know what to do with? see the pic please

The ones i cant get in to are as follows which shows up with this error  when i click on them:  Error

  • NTFS Volume 1 (System Reserved) 100mb
  • Volume 1 (Primary, Linux) 489.00 MB
  • Volume 2 (Primary, Linux) 1858.71 GB
  • Unallcated space  (All of them)
  • Physical Drives (All of them)

The only two drive i can get in to are as follows: (click on them for the pics)

Hope this will m ake sence to you as i have got no Idea of what to do from here…  :(

Kind Regards,

Ali 

Oh! and i have download the R-Linux see hereplease :slight_smile:

Yes you will have to use r-linux. The partition with the data on it would be the one listed as F: in your screenshot

You will have to click on F: and then up top hit the scan button I believe. This is because you deleted the folders and files when you did a quick factory restore. The program should be able to find and recover most if not all of your data depending on how much data you added to the drive after the factory restore. Make sure you recover the data to another drive other than the MyBookLive drive. (example, your windows drive) Let me know how you make out. As long as the filesystem isn’t damaged on your data partition, that program should work like a charm.

Here’s the manual if you run into any issues recovering your data

http://www.r-tt.com/downloads/Free_Linux_Recovery_Manual.pdf