MKV's stutter after about 10 to 20 seconds of play back

Hi, New to the forum but I have been trolling around for a while trying to find a fix for this problem.

Basically this is the rundown.

I select a MKV to play and it starts up and plays fine for a few seconds then the audio cuts out and it stutters the rest of the way. Now if I push fast forward and then play it will play regular for a few seconds and then again audio cuts out and its all stuttery.

Now I have looked on the forum for an answer looking at bit rate all the way to trying to stream it from a different media server UPNP and still a no go.

The mkv that I am using for a test is only 10 meg bitrate (from media Info) so thats not the issue. Also I am streaming it from my PC via cat 5. I have tested the line and its defiantly fast enough. I guess it just frustration because everything else plays fine but MKV’s and thats the main reason I got the player.

My father has the same device and has the same issue as I do with a lot of his MKV files as well, he cannot stream them from PC but if he puts them on a flash drive they play fine.

Anyhow I am on the latest firmware ( but I have tried downgrading to older ones to see if this fixed the problem but it did not)  Hope someone can help out


Hey there…have you tried plugging directly into the USB on the unit itself to see if you still have the problem? I’ve never had an issue when plugged into the unit directly with my external HDDs

Now I have my externals plugged into my PC and my WD TV LIve networked to my PC. I never have any problems streaming video to my unit unless I’m downloading from newsgroups at full speed…only then will I sometimes get video stutter to the point where I have to stop and then resume. At least I THINK it’s because I’m downloading…its the only time its happened.

Are you downloading a lot while watching?


I had the same problem, but finally was able to fix it. In the video settings, I changed the HDMI setting from AUTO to 1080i50, which is the format of my HD files. The stuttering was gone completely. My theory is that the WDTV HDMI AUTO setting defaults to another resolution and framerate, needing a rescaling in realtime, on the fly, which could easily overload the WDTV if HD videos are played. Try to set your HDMI setting to the format of your video.


This article should help you out

I shouldn’t have to backdate my firmware. If WD is breaking things by updating you to a new firmware, I would like to think they would announce that they caused an issue and that new firmware is coming out to fix the new issue.

I too am having this issue. If I hook up an external HD, the movies play just fine.

I used to be able to play them just fine over my home network. I have the WD unit hardwired through ethernet to my router.

I have had this same dilemma with every firmware update since 1.02.21. I have updated each time a new beta or final release comes out. I always have to go back to 1.02.21. It is the only one to run mkv’s without the dilemmas for me. Matter of fact, the latest firmware caused my avi’s to experience the same stuttering & no sound issues. I downgraded back to 1.02.21. Actually, the newest firmware 1.04.17 even causes disconnects from my internet service. I don’t have time for those issues. I have even run mkv’s through Handbrake to make them smaller. The same stuttering always unless I use 1.02.21. I will continue to use this firmware. You may try 1.02.21 if all else fails. I’m tired of trying newer ones only to get the same results.

I read the artical but Im almost positive I tried those two firmwares and still had the problem, but I guess I will try again :smiley: Thanks for the tip.

Im also going to give the HDMI setting a try, see if that helps.

I havent tried hooking it up directly but I think it would work then, at least my father has gotten his to work that way

Thanks for the help.

Thing is, there’s no point buying a media streamer and finding yourself tied to ethernet or playing via a connected USB drive. I chose to downgrade (as pointed out in the article: because I want the freedom to stream from a NAS over powerline or wifi.

Yes, WD should acknowledge that there’s a problem with their firmware but while waiting, b-rad’s firmware is the solution and to be honest, it’s so much better. I used to wait a minute for the device to boot up whereas b-rad’s loads in a couple of seconds. It’s awesome.

I had the same problems.  Couldn’t stream reliably over wifi (rosewill N dongle) so I ran Cat6…still stuttering.  SO I bought a gigabit switch…still stuttering.

What worked for me was rolling back to firmware version 1.03.49_B.  You have to open the .ver file (textedit or notepad) and change the name to something like 2.03.49_B to get it to work.  Once you rollback the firmware, DO NOT update (after it reboots).  Continue to ignore the prompts to update.

Now, I’ve played everything from 1080p .avi and .mp4 all the way up to >10GB 1080p HD .mkv files with no stuttering or lag whatsoever!!!  There has been only one file that shook in the slightest and it was a 9GB HD .m2ts file but it does that even on the USB drive directly connected.

I’ve read about B-Rad and his site and I’m glad there’s that option but for me, I’m fine with the old firmware.

BTW, I’m streaming from a hackintosh with USB (that’s right) hard drives (2.0 not 3.0) connected from my office.  I’ve got about 5000 movies, 300 TV series (all complete or up to current seasons), 200 Anime series, over 1TB of saved sports and lots other random vids not to mention home movies/recordings of our kid’s recitals/events/games…well over 10TB of media!

I love this player and plan on buying 6 more if they get the firmware sorted.  For the price and with it’s claims, it should definitely be able to handle simple HD and SD streaming wired!!!

I’m disappointed that the latest firmware is so glitchy but since there IS a solution, I can’t find it in my heart to complain too much…at least, not yet.

Hi. I switched to the TVersity media server (Transcoding turned off of course…very important)

I was surprised at how well it worked. Even smoother than the previous firmware. Connecting is smoother and playing from FF is quicker.

Don’t knock it till you tried it.

I just wanted to report back that for me…

I uninstalled the entire Windows Live Essentials package and that fixed everything. I am now able to access my network shares without any issues.

I was reading another thread about uninstalling the Windows Live Login Assistant or ID assistant or something to that effect to fix my issues accessing my network shares and sure enough, that fixed my issue there.

And being on the 1.03… version of firmware fixed my MKV stuttering problem.

I had the same problem with some .mkv files and all i did was a (5 minute job) transcode through MKV merge.

So far it fixed them…