Mkv play bug. Appears to ignore the "aspect ratio" flag but only in mkv. I encode with handbrake


#1

I have WD Elements play 2TB ,  v1.01.10

mkv play fails

(1) mkv generates with mkvmerge v 4.4.0 fails.
working mkv stop playing if you add some item with mkvmerge.

(2) mkv generates with handbrake v 0.9.4, work fine… but.
aspect ratio fails, for example option “loose”. WD don´t care about reescale…
image apear like 4:3 when his natural aspect should be 16:9
This mkv works fine in another players such us VCL.

(Aspect ratio flag, works fine with DvD/ISO format and with AVI format)

Any idea? It´s a bug? Is going to be fixed in a future firmware revision?

Perhaps I´m doing somethig wrong…

thanks.


#2

Yes, it’s a bug…

BTW, I recommend you upgrade HandBrake…  Version 0.9.5 was released last week…    


#3

It´s a bug of  WD?  (Not handbrake, I understand)

I´m going to install the new handbrake and codec the same film with the same settings.

BTW I have to say that I send the question to WD, (I´ve register my HD) last week.

I have no answer, yet.

I don´t care the bug … if only they told my the truth and promise to fix in the new firmware.

What abaut mkvmerge. I make a mkv with 2 languages, but if you try to add subtitles don´t  work.

One more question about handbrake…

I´m trying to get a good Presets configuration, reading manual and making tests…

Perhaps experts of the foro could obtain a better preset.

I began with “High Profile” and my goal is the best quality. I don´t care about time encode. Nights are long.

thanks.


#4

Yes, it appears to be a WD bug, not a Handbrake bug.    The same files play correctly on all WD Sigma-based players.

The Elements and Mini are AmLogic-based players.