Mkv freezing

I am about fed up with this and on the verge of switching to seagate’s streamer. I love the player and I really hope I can get to bottom of this without having to switch hardware. Here is my problem and what I have tried to resolve the issue with no luck.

So, I have been using makemkv to rip my bluray collection into, on average, a 20GB .mkv file. I am then uploading this onto my mybook live 2TB cloud/twonky server. Connection to server from wdtv is through 10/100/1000 Cisco e3700 router.

Problem: Video playback is freezing at random points across all movie rips.

What I have tried as a solution;

1 - tested playback on an alternate device - SUCESS
2 - reset firmware to factory default - FAILED
3 - updated to latest firmware - FAILED
4 - shut off UPnP on router - FAILED
5 - updated firmware on MyBook - FAILED
6 - tested network - PASSED
7 - wdtv was extremely hot, added a 5v 80mm USB fan - FAILED
8 - switched audio output settings on wdtv - FAILED
9 - turned off my media library - FAILED

Alternatively, I have used handbrake on a few movies for cloud streaming and those all play on the wdtv with the exception of stuttering on graphic intense scenes. I do not get this stuttering with playback on iPad or iPhone through the cloud.

Questions: Is anyone else experiencing these issues? Is there a solution?


1 - media files are too large. Can anyone confirm playback of 20+ GB .mkv files without issue?
2 - defective player? Although it was running flawlessly with Internet .mkv rips. I have since deleted all of these rips and only started experiencing the issue when I acquired my bluray drive and started ripping my own bluray collection.
3 - am I not properly ripping the media files? Makemkv is pretty straightforward and the files are flawless on Mac and PC playback.

I have contacted tech support and tried everything they requested to no resolve. I am considering to test a third party firmware as I am completely out of options at this point.

Full-resolution blu-ray rips made with Makemkv should work just fine with the SMP.  I have never had any issues at all with such files when using wired-connected SMPs.  Wifi and powerline connections were another matter, however, with rebuffering on high bitrate videos.  Our media files are served via Samba running on a Linux PC.

Are you using DNLA server or shares on the NAS?  My experience is that shares work much better than DNLA servers.  If you haven’t tried shares then I would suggest you try that first.

Another thing you could try to determine if your unit is defective is putting one of the problem files onto an external drive, plug that into the SMP, and play it from there–bypassing your network gear and NAS server.  If they still won’t play without hanging, etc., then your unit is almost certainly broken.

I have the very same issue and, like you, have been unable to find a solution, either on this forum or by trial and error.  I use makemkv to rip blu-ray discs and transfer the resulting .mkv file ( typically 15 - 25 GB) to a WD MyBookLive 6 TB.  Files are streamed to my WDTV Live via an ethernet connection, and I use network share as the content source.  I am using the latest firmware, but the problem was also occurring prior to the most recent firmware update.  Video playback freezes at random points, although it seems that this usually occurs beyond the midpoint of the movie.  The problem does not seem to occur with smaller file sizes, such as TV shows.  The only thing I can do when the freeze occurs is a hard reboot by pulling the power cord from the back of the unit and then plugging it back in.  If anyone has any suggestions, I would be most appreciative, as this is quite annoying.

Jstreit, we are indeed having the identical issue. I am in the process of attempting to play a file from an attached USB drive. I will be sure to keep you updated with the outcome.

10 - USB drive directly connected to WDTV with network cable unplugged - FAILED

This pretty much rules out the mybook and network leaving makemkv or the 27GB file being the culprit.

J- are you using makemkv on a MacBook Pro by chance?

Nixsun - please do keep me updated on any progress you make on this issue, and I’ll do the same.  Mine is a Windows 8 setup, instead of MacBook Pro.  Here’s an interesting observation:  I first had this problem when I started using the WDTV Live a little over a year ago.  At that time, I had a MyBookLive 3 TB for storage.  As now, I had been unable to find any explanation or cure for the issue.  Eventually, the problem just disappeared on its own without my having done anything at all, which I attributed to firmware updates for lack of any other explanation.  Then, a couple months ago I replaced the 3 TB drive with my current 6 TB drive and, voila, the same problem all over again.  Beats the **bleep** out of me as to what causes this.

It appears to me that the problem relates to MakeMKV itself.  I tried using Pavtube ByteCopy instead of MakeMKV and had no problems whatsoever.  ByteCopy is not a free program, but other freebies, like HandBrake, may very well eliminate the problem, as well.  It’s a shame, because I like MakeMKV and had used it for quite a long time without incident.  At least it no longer beats the “heck” out of me what the problem is.

It would for me cause my files made with MakeMKV do run. Have you tried remuxing such a file with MKVToolnix?

Bytecopy does not have a version for OSx so I am out of luck there. I am attempting the remux with MKVToolnix, however this looks like a time intesnsive process.

Can anyone recommend an alteranative to makemkv that operates on the OSx platform? I do not mind if the software has a cost as long as it does the job without error.

techflaws, could you please share the version of makemkv that you are using?

I am using MakeMKV BETA v1.8.0 [darwin(x86-release)]

1.8.0 Win with WDTV profile (which souldn’t make a difference in your case, it’s only for subs).

I’m having mkv freezing issues over a wired network too. Can you tell me what WDTV profile you are using since most of my mkv’s  have subtitles. Some of the subtitles are not showing up either?

I believe I have pinpointed my issue to an out of date version of makemkv. I have have not been having issues since.

Subtitles from blu-ray will not play on wdtv. You need to remux the files with mkvtoolnix.

I am not sure what you are referring to with the wdtv profile.

Newer versions of Makemkv have a wdtv profile that will result in compressed subtitle tracks that play properly on the WD TV units (so you don’t have to compress them with mkvtoolnix).

Which has been mentioned in the stickies of this forum for ages.

Thanks for the information ncarver, I had no idea that profiles even existed. Looks like I will be ripping my movies for a third time now…:smileyvery-happy:

Nixsun wrote:

Thanks for the information ncarver, I had no idea that profiles even existed. Looks like I will be ripping my movies for a third time now…:smileyvery-happy:

If you have already remuxed earlier rips to fix (compress) subtitles there isn’t any reason to re-rip them with the wdtv profile; you will get the same result as you already have.