MKV File Trimming Needed


#1

Thanks to the posts here I can now watch MKV files from my pc downstairs to my HDTV upstairs in the living room.

I have a few MKV files that need modifying. 

When I play the MKV file on my pc, my pc plays the correct audio file but when I play the same MKV file upstairs it chooses the wrong audio file (another language).  So I either need to make the english audio file the default or I need to delete the non english audio file from the MKV.  I used MKVmerge GUI to remux, I unchecked the audio file I didn’t want but the end result MKV file was unplayable.  What did I do wrong?


#2

If you’re not on the latest firmwares, it’s likely that your new .mkv file now has compression in the headers.

Delete the bad file that won’t play.

Go back into the MKVMerge GUI and load the original .mkv file and uncheck the audio track(s) you don’t want.

It wouldn’t hurt to make sure that the English audio track you’re keeping is set to “Default” as well.

Before you click on “Start Muxing” go to the “Extra Settings” tab and make sure that “Compression” is set to “NONE” for all the tracks you’re keeping (both audio and video).

Then when you mux it, you should get a good file.


#3

I have the latest firmwares and my WD Live TV Plus plays all my mkv files just fine without any MKVmerging. 

Just a few mkv files have mulitple audio files included and for some reason, WD Plus picks the wrong audio to play.


#4

I was just trying to figure out the “unplayable” part…  other than the header compression issue in older firmwares, I’ve never encountered .mkv files that “won’t play”.

So, if it’s not header compression, all I can suggest is making sure the English audio track that you’re keeping is set to “default” in MKVMerge before you re-mux the file to take out the unwanted audio.

If there’s still a problem, you might have to post the MediaInfo data for the re-muxed “broken” .mkv files.


#5

As I remember it, the Live ignores the default flag for subtitles and I suppose this is true for audio tracks too. If you set the track you want as the first track, it should play. (And I think it requires a double-pass through MKVmerge, I remember messing quite a bit around with it to get it to work).

The reason the pc chooses the right track is, that it respects the default flag.

Cocovanna

Edit: Just read you first post again, my reply wasn’t much use to you. You may try to post the mediainfo for the unplayable file.


#6

OP it is unclear in what you wrote, regardless of WDTVs issues with using a default flag, whether  you are able to select the correct one and if it plays. Is it that

a) you can’t select the correct one;

b) you can and it will play on your PC and not your wdtv; or

c) whether you just want not to have to select the correct audio.

In the case of #b) it could either be old firmware plus compression on some mkv making programs (the new WD firmware fixed this and most programs now don;t default to compression) or that your Living room TV can’t handled the file type (entirely possible with DTS and some TV’s) or that the order of devices being turned on can affect audio over HDMI in some set ups.