[mkv] Dual Audio - 2nd channel out of sync


#1

Howdy WD & community, I have bug to share + a fix for it.

With some MKV files the second audio channel is always out of sync. The first channel (default channel) works great. I tested the files in VLC player and both channels where not out of sync so I figured this was a WD TV live issue.

Tracks inside the MKV (copied from avi-mux):

  1. video: V_MPEG4/ISO/AVC
  2. audio: AC3 (VBR, 2Ch, 48kHz, 44.4Mbyte, eng, default)
  3. audio: AC3 (VBR, 2Ch, 48kHz, 44.4Mbyte, jpn)
  4. subtitle: Vobsub (eng, compression: zlib)

T** he solution**, in my case I wanted to have Japanese audio:

  1. Open the program AVI-Mux
  2. Open the MKV file inside AVI-Mux
  3. Drag the 3rd track above the 2nd track so that this will become the 2nd in place
  4. Uncheck English audio and unset it is as default and mark Japanese as default
  5. Save the new file (pressing start)

If you did it right it would look like this:

  1. video: V_MPEG4/ISO/AVC
  2. audio: AC3 (VBR, 2Ch, 48kHz, 44.4Mbyte, jpn, default)
  3. subtitle: Vobsub (eng, compression: zlib)

This fixed the problem for me. However I did had change 62 files, which was a a hell. So I recommend you first try this with one file to see if it worked with your files.


#2

Well, it’s definately not an issue with WDTV Live.   I have movies with 4 or 5 audio tracks.

But here’s the question:  I’m guessing the English track is a DUB, and Japanese is the “Original” language?   If not, then how the heck do you know it’s out of sync?   With English Dubs of Japanese movies, it’s usually the other way around, at least for the dialog.  ;)