Mkv Audio out of Sync


#1

So I have a movie thats in MKV that I copied directly to my LiveHub. Sound lines up perfect on PC but when I play it on LiveHub the audio is way out of sync. What can I do about this!


#2

Try converting it to another file type - that usually does the trick. In almost every case i’ve seen of this the file is not a “real” mkv, or has issues with it’s encoding. Sometimes simply re-encoding to mkv will solve the issue.


#3

You could try re-muxing it in MKVmerge GUI: open it up and save it with a different filename.

No loss of quality and shouldn’t take long (couple of minutes or more).

Might be best to grab an older version of MKVtoolnix (4.0.0 or older) to avoid the header compression issue, or remember to disable it if using a newer version.


#4

I’ll try these it just is weird. What I have been doing was downloading a movie in MKV format supposedly 1080p. I would then convert it to mp4 so it would play on my xbox 360. The reason I bought this ■■■■■■ was to copy the MKV directly to the HDD and not deal with converting. I don’t understand why the sound is wacked up on ever MKV. 


#5

Can please WD give us a fair response on this problem?

I have it too…

My file is MKV for sure!

Here are some info:

Video:

   H264 MPEG-4 AVC  (PART10) (AVC1)

   Framerate: 23.976

Audio 1:

A52 Audio (aka AC3) (a52)

48000Hz

Audio 2:

DTS Audio (dts)

48000Hz

In both sound tracks i have a huge delay while using WD TV Live Hub and none of the delays seem to be present while viewing on PC.

Can you please explain this to me?

Thank you


#6

I have the same problem.  I have mkvs that i’ve ripped from dvds i own.  My pc plays them fine.  Boxee Box plays them fine.  However, the WD TV live plus has horrible audio sync problems.  Seems to clearly be a WD issue.


#7

If you’re using Framerate Matching in the latest firmware, try disabling it. There is definitely a problem when playing back MKVs with a source FPS of 23.967 or 24.


#8

I can’t find that setting on my WD TV live plus.  Could you please direct me?


#9

WREKKER wrote:

I can’t find that setting on my WD TV live plus.  Could you please direct me?

Its only on the live hub. That answer was given because this is the live hub forum.


#10

How do you do this on the hub ? I think i’m having the same problem with one of my files.


#11

nath999 wrote:

How do you do this on the hub ? I think i’m having the same problem with one of my files.

Use the latest firmware. Select auto hdmi and then answer no regarding the auto framerate question.