MKV audio gradually loses sync

After a selection process to chose the best container, I chose MKV and ripped 200 DVDs using Handbrake with AC3 passthru. Spot checks seemed to indicate everything was fine, but now I’ve watched a few movies I find that the audio gradually loses sync and after 10 minutes makes the films unwatchable. I just upgraded to the latest firmware and that has made no difference.

Searched the internet and header compression seems to be an issue with WD, so I tried mkWDclean. If I play a file that has been cleaned the WD puts the circular buffering symbol up, but nothing happens. From that point on nothing plays and I need to reboot.

Tried searching countless posts and some people have reported similar about a year ago (on really old firmwares for obvious reasons) and mkwdclean was the answer. Nothing recent been posted, so firstly does anyone experience similar?

Any ideas what I could do? (I sure has **bleep** don’t want to rerip the DVDs as my PC was running a solid month to create the MKVs.)

Thanks in advance

What version of HB did you use?     0.9.4?   If so, that’s old stuff…   Yeah, it’s the latest official release, but they’ve made a LOT of improvements to it since then.

None of my material loses sync, and none of the current WDTV Live firmwares have any issues with MKV Header Compression…

Yes I did use 0.9.4 as it is the latest official release.

My thinking was that by using an official release I would cause the least amount of potential problems. Basically I was playing safe on everything, which is why I’m dismayed that I now can’t watch anything.

Surely if 0.9.4 had problems they would be talked about more and I haven’t heard anything bad about it, so far…

Should add that all the MKVs play fine on VLC, which inclines me to think the problem is not the encoding but the WD.

FAQ 4C speaks to that…

rb_stretch wrote:

Should add that all the MKVs play fine on VLC, which inclines me to think the problem is not the encoding but the WD.

Just to elaborate on what Tony is saying, here’s a quote from the VLC homepage:

With VLC, there is no need to continually update many different codec packs. VLC comes with nearly every codec built in!


And whats more, VLC can play back your files, even if the media is damaged! Missing or broken pieces wont stop VLC. All the video and audio information that remains can be played.

That it works in VLC means little, other than VLC was able to play the file regardless of whether it was encoded properly or not.

You should definitely look into the more recent nightly builds of Handbrake; as Tony says, there have been many improvements to Handbrake since the 0.9.4 release.  I’m not sure why they refuse to issue a new official release, as the few Nightlies on Windows and OSX I’ve tried have been very stable…

OK I picked the wrong player with VLC. It also plays fine in Windows Media Player, so pretty convinced the encoding is fine.

Having had my PC on for the last month ripping, I’m desparately trying to avoid trying to re-encode.

To be honest if it came to that I would look at another media player. The whole reason I did a bunch of testing before ripping was to be sure I had a format that worked and with spot tests MKVs were fine. The problem only occurs if you watch a movie for say 10 mins as the syncing issue gradually gets bigger and more noticeable until it is unwatchable. If you jump to half way through it will be synced fine, therefore the only workaround I have is to stop the movie every five mins and resume play - not a realistic one at the moment.

FYI Handbrake 0.9.5 was released Jan 03, 2011

One new feature is Blu Ray support

Busy still trying different things to figure out what is going on. Interestingly I’m getting the same syncing issue with mp4 videos created using DVDFAB.

On the cables side I am using only HDMI cable to the TV and using the TV speakers, so don’t think the syncing problem is with the output.

Running out of steam on trying to figure this one out. I guess the next best option is to try to change the audio format to something like mpeg audio. Anyone with a view on what’s the best free tool to convert audio within mkv?

Just tried an older MKV I made using (I think) the old official Handbrake 0.9.4.

45 minutes in and no sync issues to speak of.  Testing another older MKV that was made with the same build now. -update- The other MKV also played without sync issues for ~40minutes.

That’s on a Live Plus running 1.04.17_B, via a Media Server connection to a NAS running Twonky.  

Digital output via Optical to a Pioneer AVR.

It might help to know what model WD TV you’re using (Live or Plus), and whether you’re playing via network shares or media server.

I am unsure of what firmware you came from, however I have had mkv playback issues with the last 2 firmware releases. If you have never used 1.03.49, it may be worth a try to rollback to that version.

PixelPower, I’m using a WD TV Live with a media server connection to a Synology DS210j. VIdeo and audio is output through HDMI.

You have given me another thing to check, though, which is to try output audio through the stereo line jacks. Will report back.

Yaho, I think I will try your suggestion. I did all my original testing on that firmware version and I don’t think I watched anything long enough to see the problem. At this stage I need to be quite methodical and sure of configurations and outcomes, so makes sense to roll back to a version that others think is good with MKV.

Ok tried different audio cable - no effect. Rolled back firmware - no effect.

What I did do is re-encode with idential settings apart form audio to aac rather than ac3. This now doesn’t have the sync issue. Have not idea why AC3 is proving problematic. The problem I now have is that I have 200 DVDs encoded with ac3.

Can anyone suggest the simplest tool to  convert mkv ac3 to mkv aac without re-encoding the video, ideally in batch mode?